Bug #12920

FLIR too bright and too dark - OA b72716

Added by cross over 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:08/14/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:


Target version:1.55.75445
Affected ArmA II version:1.53 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:


When using FLIR the non-heat source environment is too dark for white-hot and too dark for black-hot.
Especially other objects rather than the terrain. This creates a homogeneous blank view which worsens the situational awareness.
So it is like black heat signatures on a totally white background or vice-a-versa.
This is compared versus official 71612

Effected OA Beta build 72716

pre_zoomed_in.jpg (296 kB) tonygrunt, 08/14/2010 14:00

post_zoomed_in.jpg (152.2 kB) tonygrunt, 08/14/2010 14:00

pre_zoomed_out.jpg (288.1 kB) tonygrunt, 08/14/2010 14:00

post_zoomed_out.jpg (185 kB) tonygrunt, 08/14/2010 14:00

71612_B-Hot.png (372.6 kB) cross, 08/14/2010 18:59

72716_B-Hot.png - beta (266.4 kB) cross, 08/14/2010 18:59

71612_W-Hot.png (396.1 kB) cross, 08/14/2010 18:59

72716_W-Hot.png - beta (183.9 kB) cross, 08/14/2010 18:59

2300_beta716.jpg - 23:00 hours beta716 (44.7 kB) seany, 08/17/2010 16:34

1200_nonbeta.jpg - 12:00 hours 1.52 (61.2 kB) seany, 08/17/2010 16:34

1800_nonbeta.jpg - 18:00 hours 1.52 (54.2 kB) seany, 08/17/2010 16:34

2300_nonbeta.jpg - 23:00 hours 1.52 (60.8 kB) seany, 08/17/2010 16:34

1200_beta716.jpg - 12:00 hours beta716 (46.5 kB) seany, 08/17/2010 16:34

1800_beta716.jpg - 18:00 hours beta716 (45.8 kB) seany, 08/17/2010 16:34

Related issues

related to ARMA2 Community Issue Tracker - Feature #12134: Thermal sights should have less contrast during the day. Assigned 07/19/2010
related to ARMA2 Community Issue Tracker - Bug #16096: FLIR unusable from start of Dec until end of March Assigned 12/19/2010


Updated by kju over 5 years ago

  • Due date set to 08/28/2010
  • Category set to Rendering
  • Status changed from New to Feedback

Please provide screenshots, demo mission and repro steps.

Updated by BigDawgKS over 5 years ago

Screenshots of pre vs post b72716 would be a good idea.

Updated by tonygrunt over 5 years ago

Added screenshots taken from mission "E07: Death from above".
FLIR view from ULB of nearest target.

Updated by cross over 5 years ago

ULBs FLIR has a green tint as well. You can notice it in the pictures tony attached.

Here are the screenshots of FLIR of US sniper.

Updated by kju over 5 years ago

Green is realistic for some I read.

Updated by q1184 over 5 years ago

It might be an attempt to address this: #12134

Updated by Fireball over 5 years ago

  • Assignee set to Dwarden

So, is it now a bug or a feature (#12134)?

Updated by Fireball over 5 years ago

Guys, are your screenshots from day or night time?

Updated by seany over 5 years ago

I have added 6 example screen shots. 3 from 1.52 @ 12:00, 18:00, 23:00 and 3 for the beta 716 at the same times. It looks to me now like FLIR is affected by the time of day, where as before it was not. I don't like the new method. Once it gets to about 16:00 you have no bearing on where you are looking, Everything is black unless it's a thermal object. It looks like your using the amount of day light to simulate how "hot" the terrain is, which is not how it works. Terrain and rocks and buildings etc retain heat for a long while after the sun has completely gone down. Unless you want to add a thermal texture for every object and terrain surface in the game leave it as it was upon release.

I also think the change in contrast in this beta is having an effect on FLIR, also making it look darker. But as I said the main problem is using light to simulate thermal which is just making FLIR useless and frustrating to use.

If you want a good resource for FLIR videos Go to www.apacheclips.com and look at their FLIR section. Every video has high contrast between terrain, objects and hot objects. None of the videos ever look a "washed out" and completely grey or black because of a lack of hot thermal feed back. Also rounds, tracers etc and ground splash are very distinguishable, which is something else I feel needs looking at. Be warned that the website has some graphic content and obviously the FLIR videos show people being killed, but it is the best source you will find.

Updated by kju over 5 years ago

  • Due date changed from 08/28/2010 to 11/01/2010
  • Status changed from Feedback to Assigned

Thanks. Lets hope to see some feedback from BI, if its intentional or not.

Updated by Suma over 5 years ago

  • Status changed from Assigned to Resolved

Not intentional. Fixed in 72744

Updated by Fireball over 5 years ago

  • Due date changed from 11/01/2010 to 08/31/2010
  • Target version set to 1.53 BETA

Updated by kju over 5 years ago

  • Due date deleted (08/31/2010)
  • Target version changed from 1.53 BETA to Upcoming version

Thanks Suma!

Updated by UGLY58 over 5 years ago

As far as I am concerned these shots show a good representation of FLIR. Far more realistic than the vanilla FLIR which is like a damn god gun. I also feel this is a game balance improvement.

However I do agree that the background contrast has to be improved. It is this background heat that hides targets from Human interpretation not hiding the target itself which is what appears to have been done on this beta. I think that if the reverse to these changes were made it would improve things. Improve the thermal return of the background, reduce the thermal returns of the targets.


Updated by kju about 5 years ago

  • Target version changed from Upcoming version to 1.55 BETA

Please confirm fixed.

Updated by Crusader about 5 years ago

Well its a bit better, but the main problems is that especially non OA models are plain white in FLIR.

The suggestion of Ugly58 sounds good though. And personally I think the FLIR image should be a lot more fuzzy as right now its pretty easy to IFF troops using FLIR, which is one of its main drawbacks IRL, IIRC.

But nevertheless, thx for the support!


Updated by kju about 5 years ago

  • Status changed from Resolved to Closed

Thanks. The plain white is a compromise for models that have no inbuilt FLIR
data in the model.

UGLY58 can you please create a new ticket for your suggestion. Thank you.

Updated by kju about 5 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF