Bug #12832

Revived Players spawn in the air and die again...

Added by BCA_Cat_Toaster over 4 years ago. Updated about 4 years ago.

Status:Feedback Start date:08/09/2010
Priority:Normal Due date:
Assignee:- % Done:

90%

Category:-
Target version:AAS Complete Pack

Description

...if they were killed in the air before (parachutes/aircrafts) and need a 2nd revive afterwards.

Seen in all OA-Betas since the Medics works again (r72291 in this case).


Related issues

related to A&S ProMode (OA) - Bug #12956: Revived unit is spawning in the air (when killed in the a... Closed 08/14/2010

History

Updated by kju over 4 years ago

Screenshot please

Updated by BCA_Cat_Toaster over 4 years ago

Nothing to Screenshot here. Dead body lies on the ground, revive, patient spawns in the air crashing on the ground and dead again, 2nd revive, all is fine.

Updated by BCA_Cat_Toaster over 4 years ago

Guess revived players are meant to spawn on the exact position they died before which makes perfect sense as it usually happens on the ground or on top/within a bulding. It´s only an issue if one dies "in the air". So it seems "where a player died" and "where his body is located afterwards for revive action" are two different conditions that are usually in the same place as long as the player didn´t die "in the air". Isn´t it possible to set it up like the revived player respawns on the position of his dead body OR on the position the medic used the revive action INSTEAD of where the "death-event" happened?

Updated by kju over 4 years ago

  • Status changed from New to Feedback
  • Assignee set to BCA_Cat_Toaster

Which exact situations does the problem occur?

Updated by BCA_Cat_Toaster over 4 years ago

All the time if you die while being up in the air in a plane, chopper or parachute. You die in the air, your dead bodies hits the ground afterwards, you get revived and spawn back in the air where you died before. If´you´re falling high enough you´re dead again. Now the revive works fine, because you died on the ground the 2nd time.

Updated by kju over 4 years ago

My approach would be to hide dead bodies in that case,
as its bit weird to be able to revive "units that came from the sky".

Updated by kju over 4 years ago

test

Updated by BCA_Cat_Toaster over 4 years ago

What´s weird for me is that you don´t get revived where your dead body is and instead on the coordinates the death event happened before which is in this case not the same. Isn´t it possible otherwise?

In the end I don´t see a real difference between reviving one from a blown up tank or a blown up chopper. It works in both cases, but in the 2nd case it has to be done twice and the process now is really weird.

From a gameplay perspective I´m fine with being unable to revive such "air-casualties" as well but in that case those dead-body-makers on the minimap shouldn´t appear so the medics on the ground don´t run for teammates they can´t revive at all anymore.

Updated by kju over 4 years ago

Should be fixed by #12956.
If you need help porting the fix, tell me.

Updated by BCA_Cat_Toaster over 4 years ago

Good job kju, thanks! Maybe you can look into my integration if that can work. Had just a small test in LAN-Mode alone and killed myself a few times. At least the Regular Respawn-System still works and no errors in the RPT showing up.

Updated by kju over 4 years ago

The merge looks fine.

Updated by BCA_Cat_Toaster over 4 years ago

  • Status changed from Feedback to Resolved

Thanks again!

Updated by BCA_Cat_Toaster over 4 years ago

hmm, I heard of two events where it still behaves like initially described. Guess I´ll have to reproduce it once myself...

Updated by kju over 4 years ago

People need to provide info what exactly happened.

Updated by BCA_Cat_Toaster over 4 years ago

Problem is still the same as initially described. Died in the Air, Respawn in the Air after revive for the first time.

Updated by BCA_Cat_Toaster over 4 years ago

  • Status changed from Resolved to Feedback

Updated by BCA_Cat_Toaster over 4 years ago

  • Assignee deleted (BCA_Cat_Toaster)

Updated by BCA_Cat_Toaster over 4 years ago

Should be fixed now, will hopefully test it tommorrow.

Updated by BCA_Cat_Toaster about 4 years ago

  • Target version set to AAS Complete Pack
  • % Done changed from 0 to 90

Should be fixed in latest public version released one month ago but still not finally confirmed

Also available in: Atom PDF