Bug #12436

[OA][74123] BIS_IAmBeingNaughty# on dedicated server

Added by ade over 4 years ago. Updated about 1 year ago.

Status:Closed Start date:07/28/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Server
Target version:1.60.87580
Affected ArmA II version:1.62 Beta First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

  • We reinstalled from scratch on a new host (Windows Vista)
  • We found in the profile these strings
  • We run multiple instances of arma2oaserver.exe on the same machine
  • We run them from separated root folders using symlinks and junctions
  • We update the betas directly on the server with the beta patcher executable and ade's key put in the registry. After the patcher has finished, we delete the BIS registry keys tree
  • Clients that connects may not have BAF

Please tell us there could be something wrong in the steps above and why we get those strings in the profile, and if this possibly triggers FADE.


Old description
ade copied his own game id windows registry key in the dedi server. This is needed to run the patcher directly on the server.
But if the key is left in the dedi windows registry, as ade connects, what happens is the following.

Old description
In .Arma2OAProfile we have many of following lines:

activeKeys[]=
{
    "BIS_IAmBeingNaughty1",
    "BIS_IAmBeingNaughty2",
    ....
    "BIS_IAmBeingNaughty17" 
}

One line "BIS_IAmBeingNaughtyX" added each day.

There are some days where we have strange behaviour while playng in our server, access problems, joining as crow and so other..
Sound like FADE activated on server?

The installation on server was made from Sprocket download, not copied from a previously installed Arma2OA, using required key for installation but without activating the game itself. We use only arma2OAserver.exe on server
The same packeage was installed and activated in my home installation, .Arma2OAProfile in my installation doesn't have any of the previous lines.

It is possible that FADE is active on our server?

BIF: BIS_IAmBeingNaughty
BIKI: Installing a patch on the dedicated server

History

Updated by Fireball over 4 years ago

  • Status changed from New to Rejected

Updated by kju over 4 years ago

  • Status changed from Rejected to Feedback

Alef will tell you more later.

Updated by kju over 4 years ago

  • Assignee set to alef

Updated by ade over 4 years ago

@Fireball
Thread in Your link is a BE feature available from yesterday, 28/07/2010, it's only needed to give Administrator right to Arma2Oa for WinVista/7 and/or, for WinXP, user must in Administrator group. It's mandatory only in client side

Problem (in our OA installation) come between 3-6/07/2010 after Beta 71900 (i think).
At 23-07-2010 we found 17 lines with "BIS_IAmBeingNaughtX" in server.Arma2OAProfile, that at ratio of 1 line per day ...
Playing problems come from 1-2 week or more, we haven't think to FADE problems before, can be that some MPmissions doesn't work fine at 100%. But presence of this strange lines, problems in game, and looking in BIS forum http://forums.bistudio.com/showthread.php?t=95806
I start to thinking at FADE problems...
Thank You

Updated by alef over 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee deleted (alef)

"BE as administrator" issue is unrelated because the thing started to happen earlier than yesterday.

We, me and ade, would like to know

  • If FADE can trigger itself on a dedi
  • If FADE triggers on a dedi, then whether the clients may be affected or not
  • If FADE triggers on a dedi because of Windows Registry BI key error
  • If FADE triggers on a dedi because of SecuROM
  • If FADE triggers because of other software running, like happened in ArmA1 for Process Explorer

Updated by Dwarden over 4 years ago

does it still happen with 72291 beta?

Updated by Sickboy over 4 years ago

Interesting to hear about the strange behaviours, joining as crow etc; we have experienced likewise issues back in arma1 - with even result of crashing server or clients.

Updated by ade over 4 years ago

Yes the running version of Arma2OAserver.exe was 72990

Updated by ade over 4 years ago

@Sickboy
Sometimes we had multiple synchronized crash, 2-3 or half or all player in CTD concurrently with, sometimes, also the server in crash.

Updated by Sickboy over 4 years ago

ade wrote:

@Sickboy
Sometimes we had multiple synchronized crash, 2-3 or half or all player in CTD concurrently with, sometimes, also the server in crash.

Back then I felt like we were the only ones experiencing that madness, but it seems you guys experience just the same!
Do you guys use CBA/ACE?

Updated by alef over 4 years ago

Yes, we use 72291 and still happens.
No, this server instance runs without CBA/ACE.
I can add I saw A2 dedi running together on another port in the same server. Can they interfere?

Updated by alef over 4 years ago

  • Subject changed from [OA] arma2OAserver (.ArmA2OAProfile BIS_IAmBeingNaughtyx) to [OA][72290] arma2OAserver add in .ArmA2OAProfile "BIS_IAmBeingNaughty#" keys

Updated by alef over 4 years ago

  • Subject changed from [OA][72290] arma2OAserver add in .ArmA2OAProfile "BIS_IAmBeingNaughty#" keys to [OA][72418] Duplicate Game ID Checked on DS Hosting Windows Registry
  • Assignee set to Dwarden

Updated by alef over 4 years ago

  • Subject changed from [OA][72418] Duplicate Game ID Checked on DS Hosting Windows Registry to [OA][72716] Duplicate Game ID Checked on DS Hosting Windows Registry

Updated by alef over 4 years ago

[72716]

I've removed the KEY registry at all, before only the content was removed.
After having restarted the server, I connected to it and got the same "naughty" key in server's profile.

  • It doesn't depend on ade's key
  • It doesn't depend on empty KEY in registry
  • It doesn't happen only when ade connects

Updated by kju over 4 years ago

  • Due date set to 11/01/2010

Updated by alef over 4 years ago

  • Subject changed from [OA][72716] Duplicate Game ID Checked on DS Hosting Windows Registry to [OA][74123] BIS_IAmBeingNaughty# on dedicated server
  • Due date changed from 11/01/2010 to 11/15/2010
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Updated by alef over 4 years ago

  • Operating system changed from Win7 64 bit to Vista 64 bit

Updated by alef over 4 years ago

Ticket updated.

Updated by alef over 3 years ago

  • Due date deleted (11/15/2010)
  • Status changed from Assigned to Resolved
  • Assignee deleted (Dwarden)
  • Target version set to 1.60 BETA
  • I am using deleted (CO (A2+OA))

No trace anymore of this in our servers profile.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Updated by i76 about 1 year ago

  • Affected ArmA II version changed from 1.55 BETA to 1.62 Beta

Still present.

Also available in: Atom PDF