Bug #12244

Animations Don't Work on Launcher Weapons

Added by BigDawgKS over 4 years ago. Updated over 2 years ago.

Status:Assigned Start date:07/23/2010
Priority:Normal Due date:11/01/2010
Assignee:- % Done:

0%

Category:Model
Target version:-
Affected ArmA II version:Please select... First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
Animations don't appear to work on rocket/missile launcher type (infantry) weapons. I'm not sure if it's a bug or just non-feature, but in any case I can't see any reason why they shouldn't work for launchers.

Exp:
Animations should play using the appropriate controllers (ex: reload, isEmpty, reloadMagazine) for launcher weapons.

Repro:
Try the attached mission using the included addon. Notice how both weapons use the same exact model, but only one will animate.

Launcher_Anim_Test.zip (282.9 kB) BigDawgKS, 07/28/2010 01:50


Related issues

related to ARMA2 Community Issue Tracker - Feature #5321: RPG-7 model with optics Assigned 10/21/2009

History

Updated by BigDawgKS over 4 years ago

Talking about model config defined animations here, not character anims.

Updated by kju over 4 years ago

  • Status changed from New to Assigned

Updated by kju over 4 years ago

Well it might be useful to attach a non working example, if you happen to have one.

Updated by BigDawgKS over 4 years ago

Yes I do, and I was going to upload it when I got a chance to. :)

But in the mean time, here's a simple repro:

1. In Operation Arrowhead, observe the fully animated M32 with revolving cylinder and reload animations.
2. Create a new configuration file that overrides the RPG7's model with that of the M32 (just for testing).
3. In game, try the RPG7 that now uses the M32 model. Fire off and reload a few rounds. Observe that the animations
no longer function, even though the animations were not changed in any way. It seems as if the animation controllers just don't work on launcher weapons.

Updated by BigDawgKS over 4 years ago

Ok, here's the promised example.

Please try the attached mission using the included addon. Notice how both weapons use the same exact model, but only one will animate.

Updated by kju over 4 years ago

tx

Updated by BigDawgKS over 4 years ago

  • Tracker changed from Feature to Bug
  • Subject changed from Working Animations on Launcher Weapons to Animations Don't Work on Launcher Weapons

I'm going to make this a bug ticket unless BIS says explicitly that it's a non-feature. :)

Updated by kju over 4 years ago

  • Due date set to 11/01/2010

Also available in: Atom PDF