Bug #12242

Zargabad Life breakage with 1.53 BETA 72197

Added by Fireball over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:07/22/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Mission
Target version:1.55.75445
Affected ArmA II version:1.53 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

The attached MP mission, which I've seen about 30 people playing together on a dedicated server, fails to load in current BETA, but runs fine with vanilla patch 1.52.

Repro Steps
- Place attached mission in "mpmissions" folder
- Start Combined Operations BETA build 72197
- Try to start attached mission in MP (Internet game)
- Accept default team assignment
- Click "Continue" at the briefing

Expected
Game starts, terrain loads.

Observed
Black "Receiving..." screen and A2 CO locks up.

Verification for 1.52
Start Combined Ops 1.52 and load the mission in MP for verification, that it loads properly.

zl17b.Zargabad.7z (189 kB) Fireball, 07/22/2010 22:56

History

Updated by Fireball over 4 years ago

Updated by Dwarden over 4 years ago

dedicated or listen server or both?

Updated by Fireball over 4 years ago

It happens for me both when I start a listen server with that map or when I join a dedicated server running the map.

So it seems more a client issue to me, since the ded. server where it happened was running the mission with others (presumably non-beta clients) playing on it - only my client couldn't join unless I started CO without beta.

OTOH, I didn't test if a beta dedicated server would lock up too, trying to load the mission.

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to Feedback

i tried host this as listen server in my client (normal via MP>new)
and i loaded fine with b72203

i think this needs waits one more beta build to be rechecked

Updated by GingerMcAle over 4 years ago

I had this problem too and tried to find the error source. The error source was the -exthreads game startup parameter. Once it was removed it did work. Iam on a dual core CPU so the exthread parameter was 0 then for me. If you have more then two cores the game does choose a exthreads value itself that is higher then 0. So try if the problem is solved for you with removing the exthreads parameter and/or setting it to 0 >> exThreads=0

exThreads has been introduced to OA with the beta patches right? Without the beta patch this parameter is not available so the mission works. It is a exThreads problem.

Copied and modified my answer from:
http://forums.bistudio.com/showthread.php?t=103133

Regards
Mariusz aka ginger

Updated by Dwarden over 4 years ago

i use exthreads 7 all the time

Updated by kju over 4 years ago

exThreads was introduced in 1.06 BETA (and active for any OA version).
It is active by default for 1.07 and 1.52 BETA (0 for dual core, 7 for quad core and above).

Updated by GingerMcAle over 4 years ago

Interesting. I tried it out now again.

without exThreads: ok
0: ok
1: crash
3: crash
5: crash
7: crash

It holds after i click on continue on the map screen. All i get is then the receiving message. Alt + Tab doesnt work. CTRL + ALT + DEL works.
ArmA 2\Expansion\beta\arma2oa.exe" -mod=Expansion\beta;Expansion\beta\Expansion -nosplash -exThreads=xxx

Win 7 - 64 bit
ARMA2_OA_Build_72197

Updated by kju over 4 years ago

What is your CPU?

Updated by Fireball over 4 years ago

Updated Repro steps.

Indeed, it runs with -exThreads=0, but breaks with anything else.

EDIT: Oh yeah, before I forget: still happens latest Beta 72291.

Updated by Fireball over 4 years ago

  • Status changed from Feedback to Assigned
  • Reproduced by another DH user changed from No to Yes

Updated by Dwarden over 4 years ago

b72291 public beta, again no problems to listen server host or be client or both ...

Updated by GingerMcAle over 4 years ago

Argh, sorry kju forgot to say that and thanks for pointing at that. My CPU is a dual core, Intel e8200.

Updated by Fireball over 4 years ago

So, it's either Intel CPUs, or something funny.

Are you running Combined Operations too, Ginger?

Updated by Dwarden over 4 years ago

GingerMcAle wrote:

Argh, sorry kju forgot to say that and thanks for pointing at that. My CPU is a dual core, Intel e8200.

tested with E8500 , still unable to replicate

Updated by GingerMcAle over 4 years ago

@Fireball: Yes.

Damn, whondering what the error source is. What else could it be hmmm. We need to find the common denominator.
I just post some other details of my system, maybe we find something together:
- ATI 4850 - 512 MB
- Windows 7 - 64 bit
- Creative X-Fi (Soundcard)
- Intel e8200 (Dual CPU)
- no software running during gaming
- Game and Operating System runs from SSD

Updated by Fireball over 4 years ago

Our configuration couldn't be more different besides the Operating System.

Using on-board SoundMax Chip, regular Western Digital BlackCaviar HDD.

I rather think it's the way how the game got installed or configured or something.

Mine is Retail (both parts) and was installed as ArmA2 only, patched throughe every patch ever appeared and then from 1.05 to 1.07 eventually, played it a while as such. Then I installed OA over it (as soon I got it) and patched it to 1.52, then the BETA patch(es).

Updated by kju over 4 years ago

  • CPU changed from Please specify! to Dual core, Intel e8200

Updated by Fireball over 4 years ago

  • CPU changed from Dual core, Intel e8200 to Core i7-920/E8200

Updated by BLUFOR over 4 years ago

I get this too. Running an Intel Core 2 Quad Q9550 @ Windows Vista 64-bit

Updated by Fireball over 4 years ago

  • Due date deleted (10/22/2010)
  • Status changed from Assigned to Closed
  • Target version set to 1.55.75445

Fixed for a while already.

Also available in: Atom PDF