Feature #12203

[OA] Add more damagable systems and indicators for fixed-wing-aircraft

Added by MoS over 4 years ago. Updated over 2 years ago.

Status:Assigned Start date:07/21/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Interface
Target version:-
Affected ArmA II version:Please select... First affected ArmA II version:
Reproduced by another DH user:No Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:

Description

Obs
Operation Arrowhead added the warning light system which indicates different status of each present system in a vehicle.
For example:

HULL - ENG (engine) - MROT (main rotor)- INST (instruments)

All fixed-wing-aircraft just have ONE indication (hull).

Suggestion
Please add following system indicators and corresponding damagable systems for planes:

HULL - ENG - FUEL (fuelpumps)- WHL (wheels)- INST

For more ideas see:
http://forums.bistudio.com/showthread.php?112456-Arma2-Aircraft-Damage

Note
It seems doable as those indications are already existent ingame.

Aircraft_hud_information.JPG (159.3 kB) MoS, 07/21/2010 17:37

Aircraft_hud_information2.JPG (123.9 kB) MoS, 07/21/2010 17:37


Related issues

related to ARMA2 Community Issue Tracker - Feature #3503: Armor Damage model improvements Assigned 08/08/2009
related to ARMA3 Community Issue Tracker - Feature #24190: Detailed component-driven damage modeling. New 09/05/2011
related to ARMA2 Community Issue Tracker - Feature #12692: Improve countermeasures and warning system Assigned 08/04/2010
related to ARMA2 Community Issue Tracker - Bug #15980: Airplanes survive too many AA missile hits Assigned 12/16/2010
duplicated by ARMA2 Community Issue Tracker - Feature #15927: Add more complicated damage model to aircrafts Duplicate 12/14/2010

History

Updated by BigDawgKS over 4 years ago

Currently, fixed wing aircraft only have one part. They do not have different damagable parts (like the ones you mentioned). All damage is taken to the hull. No longer seems like such an "easy fix" does it? :\

Updated by Fireball over 4 years ago

  • Status changed from New to Rejected

Updated by HailStorm over 4 years ago

Actually, wheels and instruments can be broken on a fixed-wing - the former can be done by landing very heavily - the failure means the pilot cannot retract the gear, and the latter can be seen when the aircraft is damaged to the point the aircrafts' texture changes to that of bullet-riddled; the pilot loses all his multi-function displays (in the cockpit) when this occurs.

OFP used to have a gradual fuel leakage from a damaged aircraft, but the effect was/is so gradual I'm not aware if it's still current in ArmA II fixed-wing aircraft.

Updated by BigDawgKS over 4 years ago

Hah. I completely forgot about the landing gear. Yea, that as around since OFP. I didn't know about the instruments and I'm skeptical about the fuel leaking being in OFP, though I think it might be in ArmA. Anyway, apart from the landing gear, those things are still tied directly to the plane's overall damage I think. They can't be seperately damaged, hopefully that will be implemented sooner or later though.

Updated by kju over 4 years ago

In OFP and a1 there was a fuel leak. Maybe the models are missing now required selections
or the engine/another hit area is badly configured.

Updated by kju over 4 years ago

  • Status changed from Rejected to Feedback

Updated by kju over 4 years ago

  • Due date set to 09/01/2010

Updated by Fireball over 4 years ago

  • Due date deleted (09/01/2010)
  • Status changed from Feedback to Assigned

Updated by kju over 4 years ago

  • Subject changed from [OA] Add newly introduced HUD information also for fixed-wing-aircraft to [OA] Add more system indicators for fixed-wing-aircraft

Updated by kotov about 4 years ago

imho - gear can be damaged only at landing and fuel leaks more likely leading to fire and destruction.
Engine/radar/flaps/weapon system failure looks much more realistic.

Updated by Fireball over 3 years ago

  • Subject changed from [OA] Add more system indicators for fixed-wing-aircraft to [OA] Add more damagable systems and indicators for fixed-wing-aircraft
  • Description updated (diff)

Updated by kju over 2 years ago

  • Description updated (diff)

Also available in: Atom PDF