Bug #12101

[OA] TOW control failing at distance

Added by Enforcer almost 5 years ago. Updated almost 3 years ago.

Status:Closed Start date:07/18/2010
Priority:Normal Due date:02/14/2012
Assignee:Dwarden % Done:

90%

Category:Game physics
Target version:1.62.95248
Affected ArmA II version:1.60 RC First affected build:Present since Cold War Crisis
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

OA Build 72107


As seen the shots at long distances make the TOW go upwards and explode. Map was Desert.
I stumbled over this by chance when trying distance shots with vehicle mounted TOW launchers ( HMMWV and M2A2 ).

I am also trying to reproduce the bug that caused the tow to drop in flight ( missile standing in mid air then dropping out of the sky still with the propellant burning ) It was not a 10000m shot, not even close to 2000m.

Rocket_Fire.Desert_E.zip - ATGM and TOW lost control after distance (1.5 kB) danczer, 09/29/2010 11:42


Related issues

related to ARMA2 Community Issue Tracker - Feature #27763: Disable locking of all non guided weapons with AutoGuideA... Assigned 01/13/2012
related to ARMA2 Community Issue Tracker - Feature #14094: Add option to restrict radar locking (TAB target cycling)... Assigned 09/30/2010
related to ARMA2 Community Issue Tracker - Bug #27418: Cannot control helicopter borne SACLOS missiles when miss... Closed 12/30/2011 03/30/2012
duplicated by ARMA2 Community Issue Tracker - Feature #11088: Manually controlled (LOS riders) missiles simulation Duplicate 06/08/2010
duplicated by ARMA2 Community Issue Tracker - Bug #27318: Wireguided missile (TOW, Konkurs...) STILL fail over 1500... Duplicate 12/24/2011
duplicated by ARMA2 Community Issue Tracker - Bug #18656: Manually Wire Guided TOW, 9M113 Konkurs, Metis AT13 are b... Duplicate 04/02/2011 04/23/2011

History

Updated by kju almost 5 years ago

  • Due date set to 10/01/2010
  • Category set to Game physics
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.53 BETA
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Yes this is an old time OFP bug.

If anyone feels like making a simple demo mission.
Like that automatically switches to the view of the flying missile.
That way it would be most easy to observe.

Updated by Enforcer almost 5 years ago

Update, bug seems to happen at distances beyond 1600m. Couldn't repruduce the dropping TOW on the Zarga though.

This bug wasn't in ArmA 1 nor ArmA 2 afaik. I used the TOW mobile and stationary a lot of times in Warfare ( before OA was released ) without problems. Maybe a retrobug?
Bug is also present in A.C.E. 2 after OA release. Tried it with the same results.

Updated by kju almost 5 years ago

It is since OFP. WGL and also ACE from what I know used scripting to avoid it.
It is only active if you manually aim - when the missile is locked onto a target,
it should not happen.

Updated by randy almost 5 years ago

how long of a control wire does a tow missile have irl?

Updated by Stang69 almost 5 years ago

3.75 km for the TOW A and 4.5 km for the TOW B

Updated by Enforcer almost 5 years ago

"Operational range up to 3,750m" http://en.wikipedia.org/wiki/BGM-71_TOW
That's way beyond what the average computer could handle view distance wise. For beeing able to shoot a target at that distance you either have to set a very high view distance or use proper view so vehicles and structures are rendered farther.
The wire should be a bit longer for safety reasons.
btw.. it's also weird that the TOW disappears after 500m.

LoL, took to long to post the message :)

Updated by mr.g-c almost 5 years ago

I remember the same bug from Arma1 already, but IIRC it was fixed by then in one of the last patches.... could be wrong though. :-)

Updated by Enforcer almost 5 years ago

Seems BIS loves to do twice the amount of work instead of leaving already known bugs out of a new game and be done with it.

It's quite annoying if you want to ambush enemy tanks and the missiles drop dead 1m in front of them.

Updated by seany over 4 years ago

Having used the Bradley a bit now I am having this bug and some others too.

Firstly manually wire guiding the missile is impossible for me unless I'm lucky for 2 reasons. Firstly the tracer on the back of the TOW disappears after about 500m so I can't tell it where it is (this makes hitting moving targets impossible). Secondly the missile (as mentioned above) falls short of the target, or it Bounces (ricochet) off the Terrain which is what is happening in the above video.

The missile should not arc up and down after launch. Basically a manually guided TOW should just follow the gun sight perfectly with a slight delay from steering, and have a continuous tracer for up to 3.7k (range according to wiki so who knows, but it should at least 3000m in OA.)

Updated by danczer over 4 years ago

I created demo mission for observe the bug.

Just simple fire ATGM or TOW horizontal above the terrain and you will see the effect.

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA
  • I am using set to OA only

Very good demo mission danczer - thank you!

Updated by Nyles about 4 years ago

It would be really great, if we could extend the missile ranges finally for manually guided systems.

Updated by zGuba almost 4 years ago

  • Due date changed from 12/01/2010 to 09/14/2011
  • Affected ArmA II version changed from 1.55 BETA to 1.59.79384
  • I am using changed from OA only to CO (OA+A2)

Updated by Nyles over 3 years ago

With the recent, awesome decrease in unit warping over distance and an overall increase in view distance since people are upgrading to newer systems, this issue is becoming more important to solve again now that you can successfully engage vehicles with manually-guided missiles over larger distances.

Please review and increase guidance range a value greater than the current 1500m losing control over missiles. Ideally this value is at least doubled, if not more. Also, please consider per-weapon tweaks to take into account the different performance stats, like wire/radio range, scope magnification, etc.

Updated by cyrilator over 3 years ago

does this missile range limitation is going to be fixed for vanila in the v1.60 ?

Updated by zGuba over 3 years ago

  • Due date changed from 09/14/2011 to 02/14/2012
  • Affected ArmA II version changed from 1.59.79384 to 1.60 RC
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using changed from CO (OA+A2) to OA only
  • Language deleted (Please set for missions)
  • First affected build set to Present since Cold War Crisis

Still present :(

And it seems to be such an easy issue to fix, shame

Updated by zGuba over 3 years ago

  • Description updated (diff)

Updated by Dwarden over 3 years ago

  • Assignee set to Dwarden
  • Target version set to Upcoming version

Updated by Dwarden over 3 years ago

  • Assignee changed from Dwarden to Suma

i think Suma may have answer if this is 'easily' fixable (and may even get into 1.60)
or something more complex for 1.61 (especially in relation to #11088 ticket)

according to real life data,
the TOW should be able shoot up to 4 km w/o problem (after upgrade to 4.5km but that's not ingame)

Updated by kotov over 3 years ago

I also suggest make it much slower than current approx speed 300m/s.According nice document http://archive.gao.gov/d31t10/145879.pdf (p19)Real speed is about 187.5ms (20 sec to cover 3750m)which also will have good impact on game play.

Updated by cyrilator over 3 years ago

This fix is a MUST. it's one of the most problematic limitation during armored battles.

TOW and Konkurs missiles are the main anti-tank weapons of Lots of armored vehicles :

-HMMWV Tow
-Stryker Tow
-Bradley
-BRDM2 Konkurs
-Bmp2
-BMP3

any attack from farther than 1500m is impossible.

I know it can be bypassed with ACE mod, but lots of servers (including the one where I usually play) don't want to bother with ACE installation.

Updated by cyrilator over 3 years ago

Still true in the v1.60 final

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Fixed in 87643 (the initial aiming point is at 1000 m now, and slides further away as needed, similar to what was suggested in #11088)

Updated by Dwarden over 3 years ago

  • Target version changed from Upcoming version to 1.61 BETA

Updated by zGuba over 3 years ago

  • % Done changed from 0 to 100

Fixed. However please take note of http://dev-heaven.net/issues/11088#note-16

Updated by zGuba over 3 years ago

  • Status changed from Resolved to Assigned
  • % Done changed from 100 to 90

The fix isn't applied to manually controlled missiles fired by gunships. See #27418

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

The fix is applied to all vehicles. If you claim otherwise, provide a repro.

Updated by cyrilator over 3 years ago

fixed ! :D

Updated by Suma over 3 years ago

  • Assignee changed from Suma to Dwarden

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

works (also for choppers)

Updated by kju almost 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF