Bug #12043

[AO] Characters and vehicles stick to rocks

Added by Vipera over 4 years ago. Updated about 3 years ago.

Status:Closed Start date:07/16/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Model
Target version:1.55.75445
Affected ArmA II version:1.53 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

During MP game I had situations when my avatar (infantry or tank) has been stuck to rocks when I was trying to climb on them. Sometimes it happens accidentialy because of collision or high driving speed. When infantry (or vehicle) is stuck to the rock it starts to jump. Some vehicles jump too high and self destructing. There are many places where I had this situation. I just give you one place for reproduction.

Reproduction steps:
- Start attached mission in Editor
- Start to move forward on the near rock (2-3 meters). Move to south direction.
- When you are close to the middle of rock you will stick to rock.

There is no way to unstick, only respawn can help.

Rock_Stuck.Takistan.rar - Repro mission (1.6 kB) Vipera, 07/16/2010 07:49

arma2oa_2010-07-16_00-16-36-66.jpg - Position on map (353.3 kB) Vipera, 07/16/2010 07:49

arma2oa_2010-07-16_00-18-22-91.jpg - External view 1 (304.5 kB) Vipera, 07/16/2010 07:49

arma2oa_2010-07-16_00-19-01-17.jpg - External view 2 (210.5 kB) Vipera, 07/16/2010 07:49

Video.wmv (1.1 MB) Pauliesss, 07/16/2010 09:17

oa_stone_model.7z (922 Bytes) kju, 11/10/2010 07:13


Related issues

related to ARMA2 Community Issue Tracker - Bug #12357: [OA] AI stuck on Takistan rocks. Closed 07/26/2010
related to ARMA2 Community Issue Tracker - Bug #1707: Collision problem: Tanks jump and at times fly high into ... Closed 06/01/2009
related to ARMA2 Community Issue Tracker - Bug #35868: [94444] Died due to glitch in DayZ New 07/05/2012
duplicated by ARMA2 Community Issue Tracker - Bug #5813: [OA] Characters and vehicles stick to rocks [Duplicate] Duplicate 11/13/2009

History

Updated by shuko over 4 years ago

I've had this happen to me once as well. I was moving on a slope and when I got to about 2-3m from a rock, it suddenly climbed on top of it when I wasn't even close enough of it. I got stuck on top/inside of it without figuring anyway to free myself.

Updated by Pauliesss over 4 years ago

This problem is already reported:
http://dev-heaven.net/issues/5813#change-57458

But maybe its good to have one for OA too. :)

Video added.

Updated by kju over 4 years ago

  • Due date set to 10/01/2010
  • Category set to Model
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from Please select... to 1.53 BETA
  • Reproduced by another DH user changed from No to Yes

Updated by kju over 4 years ago

It is a problem per rock model. So multiple reports are just fine.

Updated by Dwarden over 4 years ago

  • Target version set to Upcoming version

Updated by randy over 4 years ago

id say this is a pretty serious issue. ive gotten stuck on rocks many times while trying to use them as cover

Updated by AGW-Grimes over 4 years ago

I concur with randy. There is not that much cover in the rural parts of Takistan other than rocks, but there are times that if you simply touch them you have to do all sorts of key movements or just die to become free of the rock and proceed.

Updated by Xeno about 4 years ago

http://www.youtube.com/watch?v=SQy0BzE8Dn8&feature=player_embedded

Just an example video of the "trampoline" rocks. Gamebreaker.

Updated by IceBreakr about 4 years ago

I use the same rocks on my new island and the issue is there, too. It is a problem with object, hopefully BIS will fix the model?

Updated by RobertHammer about 4 years ago

Yea , probably the geometry LOD on rocks is broken - basicly all rocks in OA are "trampoline" rocks

it's annoying and looks very silly

This should be fixed on next full patch - i hope

Updated by Raquel about 4 years ago

randy wrote:

id say this is a pretty serious issue. ive gotten stuck on rocks many times while trying to use them as cover

Yap.... please fix this, voted

Updated by mrcash2008 about 4 years ago

I cannot begin to describe how important this is to be fixed. I would say its the largest bug from OA since release. Taking into account all OA maps have rocks and this is the same throughout ... that's a lot of potential issues over the map.

This is in general and not just MP, I got stuck "inside" a rock before and also have had situations of walking between 2 rocks roughly a meter apart and I have been stuck walking 1 foot in the air and could not release myself using jump, prone, or anything.

This get a massive vote from me.

Updated by Dmitri about 4 years ago

This must be the geo\roadway lods on the models themselves.

Why do these rocks have roadways to begin with? They should just have geo meshes, it's not like any of us are attempting to scale them. Certainly the larger rocks having a roadway is redundant.

Duplicating a roadway geo from a simplified version of the visual lod isn't "enough", it's much better to produce a much simplified version of the visual lod. I don't mind seeing the occasional "floating foot" if it means not dying near an object.

We have more fatalities on our server from this than enemy fire : )

Updated by Fireball about 4 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from Upcoming version to 1.55 BETA

Resolved in current BETA!

I've been walking/climbing over rocks on foot and with a HMMWV, behaviour all realistic to me.

Updated by Fireball about 4 years ago

  • Status changed from Resolved to Assigned
  • Target version changed from 1.55 BETA to Upcoming version

Dammit, been trying the wrong rocks, shoulda used the repro. Maybe some progress is made though.

EDIT: http://www.youtube.com/watch?v=-i5L_CSMcXM

Updated by Pauliesss almost 4 years ago

Still present in ARMA2:OA Beta 74630.

Updated by Xeno almost 4 years ago

And probably will be present until we get the data changes with the full patch too :)

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Hopefully fixed in 75230, please, test.

Updated by kju almost 4 years ago

  • Due date deleted (10/01/2010)
  • Target version changed from Upcoming version to 1.55 BETA

Updated by kju almost 4 years ago

Looks good here. 5 of the 6 test case no longer cause issues.

The small stones still do, but that seems a model issue.
As people said in BIF, at times the camera is shacking quite a bit
when running into a stone and not being able to move on.

Updated by kju almost 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Updated by Vipera almost 4 years ago

I am satisfied with the current fix.

Also available in: Atom PDF