Bug #12016

Please tighten up the dispersion on.. well... everything.

Added by Jester814 about 5 years ago. Updated almost 4 years ago.

Status:Rejected Start date:07/15/2010
Priority:Normal Due date:
Assignee:q1184 % Done:

0%

Category:Config
Target version:-
Component: Affected Version:
Close Reason:

Description

Since OA I've pretty much been using only the MK17s. Once ACE came out for OA though, the MK17 dispersion went to all hell. I can barely hit a target at 300m it's so bad. It's several feet off in any given direction when I fire. The SCAR MK17 is an accurized 7.62x51mm battle rifle. It should be one of the most accurate rifles in the game. Instead it seems to be wildly inaccurate in ACE. I don't understand the reasoning behind this.

Also, the M4 in regular ArmA 2 ACE is much less accurate than the m-16. This is simply not the case. The m-4 should be every bit as accurate, with the only difference being it's ballistic table. It's round should impact at 250m where the m16 impacts at 300m. They are both extremely accurate rifles. The m16/m4 family is world renowned for it's accuracy above all else.

It has to do with rifle accuracy. 1moa= ~1inch per 100 yards(it's actually 1.047in at 100 yards)

M16s with standard m855 issue ball ammo shoot under 1moa IRL. It's one of the requirements for the military contracts. Meaning every 100 yards the shot will be within 1 inch of where you aim. So at 500 yards the shot will hit within 5 inches of where you are aiming once you adjust for wind and bullet drop. In arma, the m16 probably shoots somewhere around 5-8MOA with standard m855(think shooting 300m on the range and hitting the target NEXT to the one you were aiming at. That was about 24in off at least. that's 8moax300yards=24 inches off), and probably around 2-3 MOA with the mk262(which is supposed to be sub .5 MOA irl). M4s are supposed to shoot sub 1moa also, but if you've used one in ACE you'll know that they shoot probably somewhere around 10-12moa.

My whole reasoning behind the request was that even with the mk262 ammo, the rifles are less accurate than they would be IRL even with standard ammo, but good enough for combat accuracy. I get very frustrated lining shots up perfectly and missing by a foot or more at 300m with a RCO in game with standard ammo.

My measurements are just from "eyeballing" it while I shoot while playing, but I shoot enough in real life and have a good enough understanding of the arma engine to be confident in my approximations.


Related issues

related to A.C.E. for OA - Feature #14087: Recoil on M4 / M16 / Scar-L family Closed 09/29/2010
duplicated by A.C.E. for OA - Feature #12100: Pistol and Rifle accuracy Duplicate 07/18/2010

History

Updated by Sickboy about 5 years ago

  • Category set to Config
  • Status changed from New to Assigned
  • Assignee set to q1184
  • Target version set to 1.5 (OA)

Updated by TheBlessedPig about 5 years ago

Can't this be a wrongly set parameter in the configs? I mean you had several reports of weapons being inaccurate and stuff...

Updated by Sickboy about 5 years ago

Perhaps. Could you please link to them? Then i'll add them as related tickets, and we can look at the bunch at once, tnx.

Updated by S2 about 5 years ago

Where do you get your information from?

Show us where it states the the MK17 is accurized.
M16s shooting M855 under 1 MOA? really? try 3-4 MOA. The M16 is not going to make a 3 in group at 300 M. Why would we even use the M24 if our rifles could hit 6 in groups at 600 M? The big thing with the military and MOA, is that they set their max point target ranges based on the 19 in average width of a man's shoulders. 3 MOA at 600 = 18 in. Just look at the M107, its max point range is 600 M for personnel, that's because its a 3-4 MOA gun as well.

Now for what it should be in game, I completely agree. The problem is, that all of those MOAs and everything are in ideal situations, on a bench, nobody shooting at you, listening to your IPOD. They have to throw in the in between by making them less accurate. It's a crap compromise but it would also be a nightmare scripting it to make you less accurate when people are shooting you.

I know when I shoot back at the enemy, I am not shooting 3-4 MOA groups. I'm shooting like 10-20 if I knew where he was at. My best shot group of 2 rounds at 150 M was about 8 in apart from each other. Which brings me to my next part. Human error. Our in game character don't flinch, blink, react to recoil (as far as countering the recoil), use bad shooting positions/postures etc.

If our characters all shot 1 MOA, after getting shot at by a BMP-2, strafed by a KA-52, and lit up by a PK, we would be just like AI.

Just use more ammo in game, and be glad taxpayers aren't having to buy it.

Updated by fireship4 about 5 years ago

I dont think combat stress should be modelled into the actual accuracy of weapons in game, they should be set as IRL and the rest left up to mission designers etc.

Updated by q1184 about 5 years ago

  • Status changed from Assigned to Rejected

Assault rifle dispersion indeed has the aiming error (multiplied by stress) counted in.

Updated by Trips about 5 years ago

Why? Our point of aim is already being yanked around when suppressed.

Updated by q1184 about 5 years ago

Trips wrote:

Why? Our point of aim is already being yanked around when suppressed.

The mere probability of being shot when in the combat zone (as an idea in your head) can already make you 'jumpy' and less prone to well-aimed shots - that depends on training and personality type, of course. In Arma the sight is always perfectly aligned no matter what - we have to compensate for it to avoid ridiculous laser accuracy in firefights. You can look up bullets fired to men hit ratio of modern conflicts to understand this approach better.

Updated by fireship4 about 5 years ago

Let me get this straight.

As currently modelled a weapon aimed properly will be less accurate than in reality due to its dispersion (accuracy) being altered to account for stress?

This is slightly disturbing to me. Can we instead do it though the ironsight moving about more or something? Or just leave it to the mission designers to make them want to stay alive (ie no medical equip/no respawn)?

Updated by Trips about 5 years ago

q1184 wrote:

Trips wrote:

Why? Our point of aim is already being yanked around when suppressed.

The mere probability of being shot when in the combat zone (as an idea in your head) can already make you 'jumpy' and less prone to well-aimed shots - that depends on training and personality type, of course. In Arma the sight is always perfectly aligned no matter what - we have to compensate for it to avoid ridiculous laser accuracy in firefights. You can look up bullets fired to men hit ratio of modern conflicts to understand this approach better.

I don't disagree with you on the principle, just on the mechanism. We're stuck with imperfect abstractions until someone comes up with a way to cheaply manufacture joystick-mouse-lightguns, but I think that dispersion (other than that inherent in the guns) is a step backward. Here's why:

With moving the player's point-of-aim you're giving the player a clear visual indicator that they will have trouble shooting straight and you're also giving them a chance to compensate and make a clear shot in spite of all else. In other words it makes decent gameplay out of a less fun but more realistic feature.

When you increase random dispersion without any cue you leave the player to guess how well they can make the shot and you leave them feeling powerless and frustrated when they couldn't despite all the indicators saying they could. That's bad gameplay.

On a related note, are there alternatives to the POA-shaking? I noticed that with pistols quite often I don't have a perfect sight picture and my shot placement is off accordingly (front sights too high --> shot placement too high, front sights to the right --> shot placement to the right). I'm sure I can get a screenshot if you like (provided I wasn't imagining it). I was wondering if scripters had any control over this? This in conjunction with the POA-shaking would be double rainbow all the way, especially if you could smooth out the POA moving to be more like Sniper Elite or CoD or Mass Effect or just about any other FPS with that kind of effect.

Updated by q1184 about 5 years ago

That's the thing, as modders we are very limited as to what we can do with POA. We cannot control shaking dynamically (apart from setting damage to hands to increase it lol). And the shaking, as you noted, is too jittery, so increasing it in configs will cause a new wave of whining, this time about your in-game character being a 70 y.o. junky. All we can do is to try and find a balance point between the unintuitive dispersion and irritating hardly controllable POA-jitter that would cause the least frustration :)

Updated by Trips about 5 years ago

Something to bug the BIS devs about then...

Updated by fireship4 about 5 years ago

Well is it a possible to add an option to turn "stress dispersion" off? Like have it as a module/opt out module? I guess that might confuse players a little mission-to-misison so a server option of some sort might be better.

I really don't like the idea much, though I understand the argument for it. Doesn't it also mean you are effectively changing the characteristics of the weapons? Not all shots fired in anger are fired under stress.

Can the shaking be tied dynamically to actual events? This seems to be present already in some form - a bullet flying very close seems to make my guy shake about (IRC), so maybe that just need to be expanded (more and more shake as volume and accuracy of fire increases?). This maybe better than the dispersion but of course there is still the argument you are interfering with a player in an intrusive way.

Updated by Naserve about 5 years ago

The problem is that even in ACE when you're sitting on the range listening to your Ipod shooting at popup targets for fun you're rifles still scatter rounds all to hell. Unless you can come up with a more exact way to only apply these inaccuracies to combat conditions please either remove it or add a way to disable it server side. When I am holding my weapon still with that optic on a target ~300 meters away and the round hits 3 feet to his left there is something wrong with that weapon, not the shooter.

Updated by q1184 about 5 years ago

Naserve wrote:

The problem is that even in ACE when you're sitting on the range listening to your Ipod shooting at popup targets for fun you're rifles still scatter rounds all to hell. Unless you can come up with a more exact way to only apply these inaccuracies to combat conditions please either remove it or add a way to disable it server side. When I am holding my weapon still with that optic on a target ~300 meters away and the round hits 3 feet to his left there is something wrong with that weapon, not the shooter.

Maybe for those occasions you fire up vanilla game then.

Updated by Naserve about 5 years ago

q1184 wrote:

Naserve wrote:

The problem is that even in ACE when you're sitting on the range listening to your Ipod shooting at popup targets for fun you're rifles still scatter rounds all to hell. Unless you can come up with a more exact way to only apply these inaccuracies to combat conditions please either remove it or add a way to disable it server side. When I am holding my weapon still with that optic on a target ~300 meters away and the round hits 3 feet to his left there is something wrong with that weapon, not the shooter.

Maybe for those occasions you fire up vanilla game then.

Then I lose the weapon variants I want to be firing on the range.

Updated by Jester814 about 5 years ago

q1184 you seem to have me all wrong. I'm not asking for perfect accuracy models from all the weapons. My issue is that some of them are extremely inaccurate(m4 and mk17) whereas the m16 and m16 with mk262 have very good accuracy comparatively.

All I was requesting is that the dispersion on most weapons be tightened up to be around the m-16 with regular ammo.

And the same with pistols. I'm not asking for G17 laser accuracy, but I've missed shots at 50m up to four feet. The USP Tactical had pretty good dispersion until a couple of months ago when it was thrown out the window. It was my go-to pistol but now I cringe at thinking of picking up any pistol at all.

p.s. apoligies for making a duplicate post about this. I thought something had bugged and this one hadn't gone through.

Updated by Trips about 5 years ago

If this is going to be rejected can we have better details on exactly how the dispersion works, particularly:
  • When is it triggered
  • How severe is it
  • How long does it take to cool down

Updated by q1184 about 5 years ago

It's config based, so it's always there. Severity - judge for yourself.

Updated by Trips about 5 years ago

Which variables do what?

Updated by q1184 about 5 years ago

Trips wrote:

Which variables do what?

Pardon?

Updated by Sickboy about 5 years ago

q1184 wrote:

Trips wrote:

Which variables do what?

Pardon?

I suppose he means config properties like dispersion etc :)
http://browser.dev-heaven.net/cfg_weapons/config/M9

Updated by Trips about 5 years ago

Yeah, sorry for being ambiguous.

Also, you say that "It's config based, so it's always there." but earlier you said that the value was "multiplied by stress". If you could explain further that would be great, thanks.

Updated by q1184 about 5 years ago

Sure. In Arma, if you are shooting, it's safe to assume you're in combat conditions (unless it's a target practice mission - an unfortunate exception).

Updated by logan9773 almost 5 years ago

I have the same question. I don't like how weapons like the M4 M16 variants seem to throw you around all over the place. I agree much more with Arma 2's version of recoil and dispersion. I do however want to keep the wind modification in ACE, so can you tell me how to turn off your modding of recoil and dispersion and keep the Arma 2 version of it?

Updated by logan9773 almost 5 years ago

I'd also like to add, that while I appreciate your mod and I think you have done some good things, other things I really disagree with. The problem is that it seems its everything or nothing. Could you make it where we could easily turn off and on things, reverting back to Arma 2 values? I see in your main config, you can do that with some things, like turning off wind, but its very few things.

Updated by q1184 almost 5 years ago

logan9773 wrote:

I'd also like to add, that while I appreciate your mod and I think you have done some good things, other things I really disagree with. The problem is that it seems its everything or nothing. Could you make it where we could easily turn off and on things, reverting back to Arma 2 values? I see in your main config, you can do that with some things, like turning off wind, but its very few things.

No, we don't do that.

Updated by Sickboy almost 5 years ago

logan9773 wrote:

I'd also like to add, that while I appreciate your mod and I think you have done some good things, other things I really disagree with. The problem is that it seems its everything or nothing. Could you make it where we could easily turn off and on things, reverting back to Arma 2 values? I see in your main config, you can do that with some things, like turning off wind, but its very few things.

What you (or anyone) can do though is write a simple override config and change/override/replace or do whatever you like :)
Documented it now over at our WAGN: http://ace.dev-heaven.net/wagn/Modification

Updated by sgtmoody1944 almost 5 years ago

On the bright side, you guys can be thankful that the accuracy of the weapons, despite the dispersion (which I don't personally find to be too bad), is still worlds better than the piss-poor, frustrating art of shooting in stuff in games such as Battlefield 2.

Updated by fireship4 almost 5 years ago

what do you guys think about leaving stress dispersion to be caused by actual player nervousness instead of configs, I do get nervous under fire in the game and may have trouble aiming. Secondly is the compromise of having it as a server-side option a possibility?

[EDIT: I realise this is basically what I asked earlier in the discussion, but i want to restate and find out the possibility of the server side option]

Updated by sgtmoody1944 almost 5 years ago

fireship4 wrote:

what do you guys think about leaving stress dispersion to be caused by actual player nervousness instead of configs, I do get nervous under fire in the game and may have trouble aiming. Secondly is the compromise of having it as a server-side option a possibility?

[EDIT: I realise this is basically what I asked earlier in the discussion, but i want to restate and find out the possibility of the server side option]

I'd opt for the former, personally. Having combat stress being multiplied onto natural weapon dispersion and a player's inability to have perfectly steady aim under fire (and the fact that the weapon already sways quite considerably from the vanilla ArmA when bullet impacts are close or when the player's character is fatigued) might be slightly overkill.

However with that being said, if nothing is done about this, I personally wouldn't necessarily mind it either.

Updated by Sickboy almost 5 years ago

fireship4 wrote:

what do you guys think about leaving stress dispersion to be caused by actual player nervousness instead of configs, I do get nervous under fire in the game and may have trouble aiming. Secondly is the compromise of having it as a server-side option a possibility?

[EDIT: I realise this is basically what I asked earlier in the discussion, but i want to restate and find out the possibility of the server side option]

Sickboy wrote:

What you (or anyone) can do though is write a simple override config and change/override/replace or do whatever you like :)
Documented it now over at our WAGN: http://ace.dev-heaven.net/wagn/Modification

Updated by logan9773 almost 5 years ago

Well, I and many other people that I've talked to think the recoil is ludicrous. So far, I've only been testing the M16 families because I've shot some of them in real life on semi. Also, the dispersion is insane. The M4/M16 family of assault rifles are the most accurate assault rifles ever produced. I try to shoot someone at 30 meters, and the rifle is so uncontrollable on full auto that the rounds land all over the place. The kick seems to be very random, sometimes very much, the rifle practically leaping up on the first shot, other times (rarely) a little up and then a huge leap, in a very random pattern, with hellish side shake. This is on the SCAR Mk16, which looks to be even heavier than the M16. Even on single shot, the dispersion is so bad that it usually takes 5 or 6 shots to get a hit. Also, there seems to be a rather large pull 45 degrees to the right. I've shot the AR-15 before, and it has a very light recoil, easily controlled. Many videos on YouTube show this. I've seen people even fire full auto with good control with one hand. Most of your mod is pretty good, but the recoil is very unrealistic. I hope you guys can find some well experienced advisors and make a more realistic recoil. I really don't find ArmA's vision of recoil to be much better.

Updated by Sickboy almost 5 years ago

Tested standing, sitting or laying down? Start of mission, in any mission, after lots of running, damage, no damage?
Please include rpt with reports, to confirm version, combination with other mods etc.
Please include the exact rifle names / classnames of weapons you test, perhaps a repro mission that includes the unit + weapon you've tested.
Perhaps include ingame video that shows what you mean.
Ultimately, if it isn't related to a combination of Mods, or caused by a bug / specific situation, best would be to provide the config settings you believe the rifles should have, so they can be compared.

Additionally, afaik recoil behaviour depends very much on FPS - is yours high/low, steady/unsteady?

Updated by Jester814 almost 5 years ago

Recoil and dispersion are two seperate things logan. Since I made this post, even though it wasn't documented, dispersion on everything was tightened up. Especially if you're using MK262 ammo. I do still agree that the m-4 dispersion shouldn't be different from the m-16 dispersion, but instead should drop sooner. But with everything else ACE provides I hate making so many tickets.

Recoil, on the other hand, seems to be 2-3x more than it should be. Recoil on all weapons in ACE is about 2x vanilla, and I feel that vanilla recoil is still a little too much. I have been a marksmanship instructor for the past 6 years. 2 of those years in the US Army, and weapons simply do not recoil straight up and just stay there. Gravity and muscle memory pull your sights back down to fairly close to where they had been with you pulled the trigger. Having to drag my mouse halfway across my mousepad to get my sights realigned on a target at ~200m doesn't feel very realistic to me.

That said, I think that the recoil issue should be it's own report. So logan I suggest you start a new ticket for the high recoil in ACE and see if they'll fix it. Sickboy and the ACE team are always REALLY fast about responding to ticket issues.

ACE v. Vanilla recoil:

http://www.youtube.com/watch?v=VQ4ePpE_tvs&feature=youtube_gdata

Updated by logan9773 almost 5 years ago

Jester - "Recoil, on the other hand, seems to be 2-3x more than it should be. Recoil on all weapons in ACE is about 2x vanilla, and I feel that vanilla recoil is still a little too much."

Totally agree with that. I really can't remember enough from the last times I've fired the AR-15 to redo the config with justice. If you would like to take a shot at it, the recoil values are in Ace_C_Weapon.pbo ( in config.cpp ). Every 3 values in the array are one shot. Its time passed, force back, force up. And usually there are about 4 or 5 of these in the array, so 4 or 5 recoils in succession in one shot. You can put in as many as you want, to get it perfect. You can make your own value for the list, Say Jester_556_Recoil, and then stick that recoil value in the weapon class itself. Its pretty self explanatory if you look at the code. One class usually inherits values from the class above it, and then passes those values down to lower classes itself.

It would be really nice to have someone who actually has a lot of weapons experience ( especially firing on full auto ) to put in realistic recoil values that reflect real life. If you have problems with the code, I can help you, its VERY simple. Its just putting in the values.

No offense to the ACE team, but I get the feeling some of you have never shot real weapons. I'm from Texas ( Gun Nut Central ), so I've had some opportunities. I also understand about the low FPS, so I try to aim at the sky when testing, using the edges of clouds as a reference. This gives me about 50+ FPS. So, its not FPS that's causing the problems.

Updated by q1184 almost 5 years ago

Please move recoil discussion to an appropriate ticket.

Updated by logan9773 almost 5 years ago

Moving to a new ticket - Recoil / dispersion too high on M4/M16/Scar-L

http://dev-heaven.net/issues/14087

Updated by Sickboy almost 4 years ago

  • Target version deleted (1.5 (OA))

Also available in: Atom PDF