Feature #11879

Specialized Command Styles

Added by Trauma about 5 years ago. Updated about 4 years ago.

Status:Closed Start date:07/12/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:Expired
Affected Version: I am using some Mods:No
Affected ArmA II version:Please select... Reproducible for you:No

Description

I would love to see some more command variety in Warfare and believe giving the commander a choice to focus on one area of military power will help to provide this variety from game to game with varying match ups and more strategies.
So I suggest specialized command styles complete with unique tech trees.

Mechanized Infantry Commander

  • Focused on infantry and light vehicle transport & fighting support.
  • Lacks Heavy Armor & Air power.
  • Heavy factory & air factory upgrades unavailable.
  • Heavy factory and air factory cost more.
  • 20% increase to heavy factory cost.
  • 50% increase to air factory cost.
  • Infantry and support vehicles and respective factories are cheaper and produced faster.
  • 30% Discount on Barracks & Light Factory units and gear.
  • 30% Discount on Barracks & Light Factory.
  • 25% prduction time reduction on Barracks & Light Factory units.

Heavy Armor Commander

  • Focused on heavy armor combat.
  • Lacks Mechanized Infantry & Air power.
  • Light factory & air factory upgrades unavailable.
  • Barracks upgrades limited to level 2.
  • Barracks and air factory cost more.
  • 20% increase to barracks cost.
  • 50% increase to air factory cost.
  • Heavy Armor units and heavy factory are cheaper and produced faster.
  • 40% Discount on heavy factory units.
  • 30% Discount on Heavy Factory.
  • 25% prduction time reduction on heavy factory units.

Air Commander

  • Focused on air power & high mobility.
  • Lacks Heavy Armor & Mechanized Infantry power.
  • Light factory & heavy factory upgrades unavailable.
  • Barracks upgrades limited to level 2.
  • Barracks and heavy factory cost more.
  • 20% increase to barracks cost.
  • 50% increase to heavy factory cost.
  • Aircraft and air factory are cheaper and produced faster.
  • 50% Discount on air factory and airfield hanger units & paratroop support.
  • 30% Discount on Air Factory.
  • 25% prduction time reduction on air factory & airfield hanger units.
  • Airfield hangers are exclusive to Air Command.

Mechanized Infantry Tech Tree

  • 35% Discount on Barracks, Gear, Light factory & Ambo upgrade cost and research time.
Bar 1          LF 1          xxxx          xxxx           Sup 1
  | - Gear 1    | - Ambo 1    | - xxxxxx    | - xxxx       | - Fast travel
Bar 2          LF 2          xxxx          xxxx           Sup 2
  | - Gear 2    | - Ambo 2    | - xxxxxx    | - xxxxxxxx   | - UAV
Bar 3          LF 3          xxxx          xxxx            | - Ammo
  | - Gear 3    | - Ambo 3    | - xxxxxx    | - xxxx       | - ICBM

Heavy Armor Tech Tree

  • 35% Discount on Heavy factory & Arty upgrade cost and research time.
Bar 1          xxxx          HF 1          xxxx           Sup 1
  | - Gear 1    | - xxxxxx    | - Arty 1    | - xxxx       | - Fast travel
Bar 2          xxxx          HF 2          xxxx           Sup 2
  | - Gear 2    | - xxxxxx    | - Arty 2    | - xxxxxxxx   | - UAV
xxxxx          xxxx          HF 3          xxxx            | - Ammo
  | - xxxxxx    | - xxxxxx    | - Arty 3    | - xxxx       | - ICBM

Air Tech Tree

  • 35% Discount on Air factory, Air lift, Countermeasure & Paratroop upgrade cost and research time.
Bar 1          xxxx          xxxx          AF 1           Sup 1
  | - Gear 1    | - xxxxxx    | - xxxxxx    | - CM's       | - Fast travel
Bar 2          xxxx          xxxx          AF 2           Sup 2
  | - Gear 2    | - xxxxxx    | - xxxxxx    | - Air lift   | - UAV
xxxxx          xxxx          xxxx          AF 3            | - Ammo
  | - xxxxxx    | - xxxxxx    | - xxxxxx    | - Para       | - ICBM

As you can see there are no additions or subtractions of upgrades, they have just been moved and depending on the Tech Tree some have been disabled.

Although changes will need to be made;
  • Base level Takistan Heavy factory needs T34 & BMP2 moved to HF 1 upgrade.
  • GRAD needs to be moved to heavy factory.
  • Parameters to disable Countermeasures & Paratroops need to be removed.
  • Shuffle units & gear available per barracks & gear upgrade level to add noticeable emphasis on barracks & gear level 3.
  • Probably others but that's all I can think of right now.

I know this would be a lot of work but I think it would be worth the effort. There will still be an imbalance in the two forces but this is just a restructuring, nothing to be added.

History

Updated by Tonmeister about 5 years ago

I like this idea. Giving sides a choice to specialise ingame would certainly make warfare a much more dynamic environment. Something like the above suggestion would negate the type of "balancing" we tend to see now where game parameters affect both sides globally. And as we see with blufor in OA, its difficult to balance sides when one is aleady quite advanced, even with their most basic weapons. A tech tree based on developing a unique ability could also mean a much more detailed tech tree could be implemented for whatever speciality was chosen.

Ton

Updated by Trauma about 5 years ago

As I said in the last line of my post there is nothing that can be done to fix the imbalance with out making it a Combined Ops warfare (which I support) and I did not add any new tech because it would already be a lot of work.

Updated by MrNiceGuy about 4 years ago

  • Status changed from New to Expired
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by MrNiceGuy about 4 years ago

  • Status changed from Expired to Closed
  • Target version set to Expired

Also available in: Atom PDF