Bug #11778

[OA] SC 48 Sector Control is missing ammo for Mk17 EGLM RCO and Mk17 TWS SD

Added by HOPEnSPIRIT over 4 years ago. Updated about 3 years ago.

Status:Closed Start date:07/08/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Mission
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Description:
Taking Mk17 EGLM RCO from the Captured Alpha or Charlie's ammo crate, doesn't give you any ammunition.
Taking Mk17 TWS SD from the Captured Bravo's ammo crate, doesn't give you any ammunition.

Reproduce
  1. Multiplayer
  2. New
  3. OK
  4. Zargabad
  5. SC 48 Sector Control
  6. Play
  7. Side: BLUFOR
  8. Roles: 1-D-1 1: Operator Group leader (to get GPS)
  9. OK
  10. Continue
  11. Ctrl+M for GPS
  12. Go to GPS COORDS 041041 and capture flag at location Alpha
  13. Step north from flag pole and open Gear at US Army Basic Weapons crate
  14. Take Mk17 ELGM RCO and notice no ammo comes with it
  15. Go to GPS COORDS 042041 and capture flag at location Bravo
  16. Go north to another room and open Gear at TK Basic Ammo crate
  17. Take Mk17 TWS SD and notice no ammo comes with it
  18. Go to GPS COORDS 043041 and capture flag at location Charlie
  19. Step north of the flag pole and open Gear at US Army Basic Weapons crate
  20. Take Mk17 ELGM RCO and notice no ammo comes with it
  21. Wait until mission ends at 12:15 to BLUEFOR WINS text
  22. second part of SC 48 Sector Control starts with error message "Script hpp\weapons_CIV_0.hpp not found"

Expected:
Add ammo for Mk17 ELGM RCO at Alpha and Charlie locations
Change Mk17 TWS SD to Mk17 TWS at Bravo location or add ammo for Mk17 TWS SD at Bravo location
Fix Script hpp\weapons_CIV_0.hpp not found error

*Notes:
In Bravo location TK Basic Ammo crate contains 300 clips of Mk17 Mag. ammo, so I think mission designer has meant to put weapon Mk17 TWS which uses that ammo, but has accidentally put on Mk17 TWS SD there which uses different ammo. All other weapons in this crate are non-SD anyway and there is no sense having SD weapon in mission like this where multiple players run around making noise anyway. That 300 clips of Mk17 Mag. is also for existing M110 TWS I believe.

After looking through MPE_SectorControl.Zargabad files I discovered that the (Mk17 Mag.) was missing from the following file:

\\MPE_SectorControl.Zargabad\hpp\weapons_box_west_0.hpp

I proceeded to implement my own fix by adding a line underneath the Mk16 version of the ammo and inputting the following text:

["20Rnd_762x51_B_SCAR",300],

On testing this fixed the issue.

http://www.andrewpearson.co.uk/Train2Game/A2OA_Mk17_EGLM_RCO_-_BUG.png
http://www.andrewpearson.co.uk/Train2Game/A2OA_Mk17_EGLM_RCO_-_FIX.png
http://www.andrewpearson.co.uk/Train2Game/A2OA_Mk17_TWS_SD_-_BUG.png
http://www.andrewpearson.co.uk/Train2Game/A2OA_Mk17_TWS_SD_-_FIX.png

http://www.youtube.com/watch?v=mRPA0aKMOBI
http://www.youtube.com/watch?v=662s3UtIeiQ

Included Fixed Files:
http://www.andrewpearson.co.uk/Train2Game/
weapons_box_west_0.hpp
weapons_box_west_1.hpp

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__15_.jpg - US Army Basic Weapons (red X) and TK Basic Weapons (black X) (227.9 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__17_.jpg - Script hpp\weapons_CIV_0.hpp not found error (198.3 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__1_.jpg - Mission start (110.3 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__5_.jpg - Mk17 EGLM RCO without bullets (382.1 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__8_.jpg - Mk17 TWS SD without bullets (310.7 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__9_.jpg - MK17 Mag. work for M110 TWS but not for Mk17 TWS SD (311.5 kB) Hanzu, 10/04/2011 12:42

SC_48_Sector_Control_is_missing_ammo_for_Mk17_EGLM_RCO_and_Mk17_TWS_SD__13_.jpg - Mk17 EGLM RCO without bullets (281 kB) Hanzu, 10/04/2011 12:42

History

Updated by kju over 4 years ago

  • Due date set to 10/01/2010
  • Category set to Mission
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Target version deleted (331)

Updated by HOPEnSPIRIT over 4 years ago

  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju about 4 years ago

  • Due date changed from 10/01/2010 to 06/01/2011
  • Operating system deleted (Win7 64 bit)
  • Affected ArmA II version changed from 1.52.71612 Sprocket to 1.58.78473
  • CPU deleted (Quad Core)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using set to OA only
  • Reproducible for you changed from No to Yes

Still in..

Updated by Hanzu over 3 years ago

Updated by Hanzu over 3 years ago

  • Description updated (diff)

Updated by Sickboy over 3 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version

Updated by Hanzu over 3 years ago

  • Due date deleted (01/04/2012)
  • Assignee deleted (Dwarden)

Updated by Dwarden over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

released as part of beta 1.60.86578

Updated by Hanzu over 3 years ago

  • Status changed from Resolved to Closed

Tested and can confirm successful fix.

Also repro step 22. second part of SC 48 Sector Control starts with error message "Script hpp\weapons_CIV_0.hpp not found" seems to be gone now.

Very good work BIS!

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF