Bug #1175

AI freeze

Added by seregavlg over 6 years ago. Updated about 6 years ago.

Status:Closed Start date:04/28/2009
Priority:Urgent Due date:
Assignee:Doomguy % Done:

0%

Category:-
Target version:Warface 1.1.8

Description

prereq: ai commander; ~5-6 hours in game

AI teams 2,4,5,6,7,8, stay and don't move
AI team 3 move to enemy hq

enemy all stay.Move after I kill 'em, but after freeze again.

AIFR.JPG (226.1 kB) seregavlg, 05/12/2009 05:32

2.JPG (191.8 kB) seregavlg, 05/13/2009 12:58

1.JPG (264.5 kB) seregavlg, 05/13/2009 12:58

History

Updated by Doomguy about 6 years ago

  • Status changed from New to Feedback

Updated by Doomguy about 6 years ago

  • Target version changed from Warface 1.1.7d to Warface 1.1.9

Updated by Doomguy about 6 years ago

  • Target version changed from Warface 1.1.9 to Warface 1.1.8

Updated by Doomguy about 6 years ago

  • Assignee changed from seregavlg to Doomguy

Updated by Doomguy about 6 years ago

  • Assignee changed from Doomguy to seregavlg

Updated by seregavlg about 6 years ago

  • Assignee changed from seregavlg to Doomguy

Updated by seregavlg about 6 years ago

After disable ace fx cartridges, ai don't freeze.

Updated by seregavlg about 6 years ago

But sometimes ai fades while to it not come nearer

Updated by Doomguy about 6 years ago

seregavlg wrote:

But sometimes ai fades while to it not come nearer

It's not quite clear to me what you mean here, could you rephrase?

Thanks,
Doomguy

Updated by seregavlg about 6 years ago

1.Enemy ai teams stay and don't move
2.When i come near ai "revive"
3.But my teams...

Updated by seregavlg about 6 years ago

Hi Doomguy! On screen squad leader.
When ai sq leader reborn mashinegunner, sniper etc this squad freeze.

Updated by Doomguy about 6 years ago

Hmm, in the screenshot, the squad leader (with machine gun) is in a camp. Camps sometimes confuse the AI's path finding, causing them to be stuck. Not sure this is really the problem, but I need some more info to figure out what is going on.

- How long into the game?
- What version of the mission?
- If you press CTRL-` you should get the debug log. Every minute the status of each AI team's squad leader is logged: "Team EAST-C is being led by...". Can you tell me what it says there (take a screenshot) of the output when you think a team is blocked?

Thanks,
Doomguy

Updated by Doomguy about 6 years ago

Also, after five minutes of being stuck, the team should be warped about 10 meters in the direction of their destination (if that is more than 75 meters away).

Updated by seregavlg about 6 years ago

sq.leader stay 40-50 min.
after i kill them

v1.17 d + latest changes

all game 3+ hours

Updated by seregavlg about 6 years ago

and:
east ai team 4
2 tanks, zsu stay and don't move 1-2 hours
I get in tank and select driver, commander, gunner
after: see screen

Updated by seregavlg about 6 years ago

Log

Updated by Doomguy about 6 years ago

  • Status changed from Feedback to Assigned
  • Priority changed from Normal to Urgent

Thanks for the reports seregavlg. I did a little testing myself and I can confirm the problem. Going to fix it!

Updated by Doomguy about 6 years ago

  • Status changed from Assigned to Feedback

Updated by Doomguy about 6 years ago

Hi,

I completely re-wrote the team AI in SQF. Please test to see if your problem is solved.

Thanks,
Doomguy

Updated by Woodstock about 6 years ago

I've tried replacing the sqs file with the sqf from here http://dev-heaven.net/repositories/revision/doomguy-waco/609 but now the team leaders do nothing, they don't recruit any team members, just stand around camp.

Do I need to replace any other files? or alter anything else? All I did was unpack mission pbo, replace the file in server/AI/Advanced and re-pack. Is this correct?

I'm running a persistant dedicated server atm so I can leave it running to test any changes you like.

Updated by Doomguy about 6 years ago

Woodstock wrote:

I've tried replacing the sqs file with the sqf from here http://dev-heaven.net/repositories/revision/doomguy-waco/609 but now the team leaders do nothing, they don't recruit any team members, just stand around camp.

Do I need to replace any other files? or alter anything else? All I did was unpack mission pbo, replace the file in server/AI/Advanced and re-pack. Is this correct?

I'm running a persistant dedicated server atm so I can leave it running to test any changes you like.

Hi Woodstock,

Thanks for testing these things out! However, it's not advisable to pick single files from the repository - many things have changed since the last release. It should be possible to use SVN to get the latest version of all files in one go, did you try that?

Doomguy

Updated by Woodstock about 6 years ago

No I didn't sorry. I'm not sure what SVN is at the moment, I'll go investigate! Thanks for the help.

Updated by Doomguy about 6 years ago

I just completed a test myself: after 9 hours all AI teams are still moving fine :-)

Updated by Woodstock about 6 years ago

That's great news. I have SVN set up now so I will keep an updated version running as much as possible. Do I need permission to access the repository for the latest files? It's giving me a "temporary" error currently.

Updated by kju about 6 years ago

Woodstock refer to this part.

Note that the pages are WIP and will be updated throughout his week.

Any feedback, problems in understanding or suggestions are very welcome!

Updated by kju about 6 years ago

For SVN anon access read this.

Updated by Woodstock about 6 years ago

thanks Kju, I'm using TortoiseSVN. I have entered that key in the "SSH Client" part. I've set the repository URL to http://dev-heaven.net/repositories/browse/doomguy-waco/warfare/branches/ace but I'm getting an error -

"repository moved temporarily to 'http://dev-heaven.net/login?back_url=http%3A%2F%2Fdev-heaven.net%2Frepositories%2Fbrowse%2Fdoomguy-waco%2Fwarfare%2Fbranches%2Face%3Foptions%255Bactivity_collection_set%255D%3D%26options%255Bxmlns%253AD%255D%3DDAV%253A'; please relocate"

Updated by kju about 6 years ago

Thats not the URL :)

Doomguy please post the URL in your (to be opened) wiki.

Updated by Doomguy about 6 years ago

The URL to use is: svn+ssh:///doomguy-waco/warfare/branches/ace

Edit: sorry, one slash too many.

Updated by Doomguy about 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF