Bug #11694

Commanding units with aiming deadzone on is extremely difficult in OA

Added by MulleDK19 about 5 years ago. Updated over 4 years ago.

Status:Closed Start date:07/04/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Interface
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

If you select some units, you can aim and click on the terrain to make them move.

It worked fine in ARMA 2 with aiming deadzone one, but in OA, the cursor which you use to aim where you want the units to move is always centered, instead of being where you aim the gun.

So if you have aiming deadzone on, you have to move your weapon so far that the camera moves, before the cursor moves, which makes it really hard.

ARMA2_Bug_CommandUnitsToMoveAimingDifficulties.wmv - Showing the bug in details (4.7 MB) MulleDK19, 07/05/2010 00:00

ARMA2_CommandAiming_HowItShouldBe.wmv (975.2 kB) MulleDK19, 07/05/2010 12:47

History

Updated by MulleDK19 about 5 years ago

Made a small supplemental video.

Updated by kju about 5 years ago

  • Due date set to 10/01/2010
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Target version deleted (331)
  • Reproduced by another DH user changed from Yes to No

Looks annoying. So in A2 not yet the case, right?

Updated by MulleDK19 about 5 years ago

It works fine in ARMA 2.

Updated by Richey79 about 5 years ago

This issue occurs for those who use a floating zone but no TrackIR/Freetrack setup because Bis have made it so the command reticule points at the center of where you are looking, rather than pointing your weapon. Of course, the new system works far better for Freetrack/TrackIR users so should certainly not simply be rolled back to the more primitive A2 system.

For Bis to make the floating zone users happy as well would involve either adding an option that allows the user to choose whether the command reticule centers on the gun's barrel or where you are looking, or the engine would need to make this choice. I.e. if no head-tracking is activated, then the reticule is centered on the gun barrel, whereas if it is activated, the reticule moves wherever the player looks.

On the other hand, even with floating-zone aiming, if you press alt and use free-view you should be able to command troops very precisely with the current system.

Updated by wamingo about 5 years ago

Richey - Before it becomes an option, however, it absolutely should be rolled back. Nothing else makes any sense. TrackIR users simply can't take precedence. They can control the mouse like everyone else.

Updated by Suma about 5 years ago

  • Status changed from Assigned to Resolved

This was introduced unintentionally when implementing muzzle climb after recoil.

Fixed in OA 719116 (the behaviour should be identical to what was before).

Updated by kju about 5 years ago

  • Due date deleted (10/01/2010)
  • Assignee deleted (Dwarden)
  • Target version set to 1.53 BETA
  • Affected ArmA II version changed from 1.52.71612 Sprocket to 1.53 BETA

ty

Updated by CameronMcDonald about 5 years ago

Suma, which beta will this be resolved in? It persists in 71952.

Updated by kju about 5 years ago

  • Due date set to 08/01/2010
  • Status changed from Resolved to Feedback

Updated by CameronMcDonald about 5 years ago

The bug persists in 72018.

Updated by kju about 5 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Target version deleted (1.53 BETA)

Updated by CameronMcDonald about 5 years ago

Glad to see this one assigned. :) It persists in 72107.

Updated by CameronMcDonald about 5 years ago

...and in 72291.

Updated by Fireball almost 5 years ago

  • Due date changed from 08/01/2010 to 11/30/2010
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA
  • I am using changed from OA only to CO (A2+OA)

Still an issue - did it get forgotten?

Updated by Fireball almost 5 years ago

  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by alef almost 5 years ago

Still in 73116. Every time you press the space key, your aim can float but the quick command cursor is stick in the middle of the screen. Please fix it!

Updated by kju almost 5 years ago

  • Due date deleted (11/30/2010)
  • Status changed from Assigned to Resolved
  • Target version set to 1.55 BETA

Please confirm fix.

  1. [73117] Fixed: Commanding units with aiming deadzone

Updated by alef almost 5 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Dwarden)

[73206] Confirmed.

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF