Bug #11609

Killer Physics - Literally (Downhill Esp.)

Added by Rommel about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:07/02/2010
Priority:Normal Due date:
Assignee:- % Done:

90%

Category:Gameplay
Target version:1.54.72888
Affected ArmA II version:1.52.71816 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Driving down hill at any speed greater than walking, will quite literally kill the crew inside that vehicle; assuming it doesn't fly into the air randomly (hehe).
Attached very obvious demonstration mission. DRIVE AS FAST AS YOU CAN between the road cones.

This has been in the engine for a long time now, but it has been very evident with OA's extended number of mountainous opportunities.

downhillkill.takistan.zip (4.6 kB) Rommel, 07/02/2010 08:28

flywithme.Takistan.zip (1.9 kB) Rommel, 07/02/2010 08:45

HillDeath.Takistan.zip - just drive down the hill and die (696 Bytes) seany, 07/18/2010 14:29


Related issues

duplicated by ARMA2 Community Issue Tracker - Bug #12053: [OA] Unit dies when driving jeeps on hills. Duplicate 07/16/2010

History

Updated by Rommel about 5 years ago

An example of physics once again, just hold E (instructions are in game). This happens a lot more frequently in multiplayer; and has accounted for 15% of our casualties in a patrol mission last night... making very prominent in OA compared to Chernarus/ArmA2.

Updated by kju about 5 years ago

  • Due date set to 10/01/2010
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Priority changed from High to Normal
  • Reproduced by another DH user changed from No to Yes

Updated by Whisper about 5 years ago

Very impacting bug.
I'll add that collision detection with rocks on slopes isn't working properly, you collide sometimes 1m away from actual rock, forcing the unit to go up or making it slide down and get hurt.
Many things like that go wrong when on slopes.

Updated by kju about 5 years ago

Whis this ticket is about something different. :)
Please open a new ticket for the bloody rocks.

Updated by tyrspawn about 5 years ago

Please fix this... this bug seriously limits the scope of missions, as well as greatly increases the frustration of players. I am a mission maker at ARMA 2 tacticalgamer, and this has negatively influenced our gameplay. And it's not only sheer cliffs which cause deaths, its even very smooth gradients. Losing 7 players in a special forces humvee on a no respawn mission is horrible.

Updated by Xeno about 5 years ago

Yeah, that's a very frustrating one. Reminds me of the MP motorcycle bug in ArmA 1.

Updated by seany about 5 years ago

Experienced this last game I had while driving a Stryker. Death while going down a slope, wheels never left the ground. This needs to be fixed ASAP. Tracked Vehicles seem fine, but with wheeled vehicles, staying on the road is the only option in OA at the moment.

Updated by Dwarden about 5 years ago

  • Target version set to Upcoming version
  • Reproducible for you changed from No to Yes

Updated by Dwarden about 5 years ago

  • Status changed from Assigned to In progress
  • % Done changed from 0 to 20

Updated by Dwarden about 5 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 20 to 90

should be fixed since b72188

Updated by mr.g-c about 5 years ago

Dwarden wrote:

should be fixed since b72188

But how did you fixed it? Vehicle-wise or generally in the engine by finally fixing the wrong g-force?

Updated by kju about 5 years ago

  • Due date deleted (10/01/2010)
  • Assignee deleted (Dwarden)
  • Target version changed from Upcoming version to 1.53 BETA

Some please confirm it fixed.

Updated by Hedo about 5 years ago

I confirm it's fixed.

Updated by kju about 5 years ago

  • Status changed from Resolved to Closed

ty

Updated by kju about 5 years ago

  • Target version changed from 1.53 BETA to 1.54.72888

Also available in: Atom PDF