Bug #11543

Vehicle commanding broken if player is not GL and enters as car gunner first.

Added by Zenu over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:06/29/2010
Priority:Normal Due date:09/01/2011
Assignee:Dwarden % Done:


Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.58.78473 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:


Cars with mounted gun. (UAZ MG)

  1. player (not groupleader) goes in the car first
  2. takes gunner position
  3. rest of the team enter the car
  4. give AI to drive car the commands via keyboard/radio
  5. wont work because for some reason the commands go for the gunner and AI driver refuses to start driving.

Work around for this is that player mustn't take gunner position before the AI driver has entered the car.

It's nice to see how co-op campaign play becomes better and more enjoyable all the time when patches come, so kudos for that.

Yesterday on one play session with my friend on Manhattan mission I still spotted some little annoyances tho that could be fixed. (playing version 1.07, vanilla)

11543.Desert_E.7z (991 Bytes) kju, 08/01/2011 07:19

Related issues

related to ARMA2 Community Issue Tracker - Bug #15293: The AI tank gunner should automatically switch to and use... Assigned 11/20/2010 10/28/2011


Updated by Sickboy over 5 years ago

  • Project changed from DevHeaven (Only site issues) to ARMA2 Community Issue Tracker
  • Affected ArmA II version set to Please select...
  • Maxmem parameter set to Not set
  • Difficulty set to Not set
  • CPU set to Please specify!
  • Audio card set to Please specify!

Updated by kju about 5 years ago

  • Subject changed from AI illogical functioning in cars with players+misc to Vehicle commanding broken if player is not GL and enters as car gunner first.
  • Due date set to 10/01/2010
  • Category set to AI Issues
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from Please select... to 1.07.71750
  • Reproduced by another DH user set to No
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • I am using set to A2 only
  • Reproducible for you set to No

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 06/01/2011
  • Affected ArmA II version changed from 1.07.71750 to 1.58.78473
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using changed from A2 only to OA only

Updated by kju about 4 years ago

  • File 11543.Desert_E.7z added
  • Due date changed from 06/01/2011 to 09/01/2011
  • Status changed from Assigned to Feedback
  • Target version set to 1.60 BETA

Added a demo mission.

However sometimes the AI GL tells the player to disembark once he is in the vehicle
(despite assignAsGunner and orderGetIn use). Seems like a bug itself.

The issue itself seems fixed in the latest beta.

Updated by Sickboy about 4 years ago

Please confirm fix, so we can close the ticket.

Updated by Zenu almost 4 years ago

Sickboy wrote:

Please confirm fix, so we can close the ticket.

Seems to be fixed. Tested the demo mission in which GL commands me to enter the car as gunner and then commands AI to take driver seat and I was able to give commands to the driver from gunner seat.

I can also confirm that sometimes in the demo mission the GL commands me to disembark from gunner seat and then mount it again in normal seat.

Updated by Dwarden almost 4 years ago

  • Status changed from Feedback to Closed

closing as fixed

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF