Bug #11479

Bullets do not enough damage over distance

Added by Moerderhoschi over 4 years ago. Updated about 3 years ago.

Status:Closed Start date:06/26/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Weapons
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
DMR, M24, SVD, M110 need 3-4 body hits to kill a standard infantry unit at distance (for example at 800m).

Fireball:
A standard M16 assault rifle needs up to 6 (!) body hits to kill a standard infantry unit at 300m.
This has been tested with version 1.54 build 73643.

One conclusion is that the damage somehow magically reduces when the infantry unit goes prone - for whatever reason - as in "on the floor it doesn't hurt that much" (???).

The second conclusion, in connection with the same test at 150m is, that there is a calculated damage reduction over distance, even though the velocity doesn't decrease notably. This is wrong.

http://www.youtube.com/watch?v=293tjNXBKNo - Repro at 150m (up to 4 hits)

http://www.youtube.com/watch?v=IVTD9PY6F0E - Repro at 300m (up to 6 hits)

Exp:
Ammo seems too loose too much power over distance.

It should be more lethal.

Repro:
  1. Load either attach demo mission in the editor
  2. Lay down
  3. Set scope to 800m
  4. Aim (see screenshots)
  5. On non headhit notice you only do 20-25% damage.

You can use 0-0-9 to activate a bullet cam (0-0-0 to remove it again).
Replace the player class with different sniper to test the different weapons.

Repro 2 (Fireball)

The Target Range attached allows you to measure velocity vs. damage done at different distances on a infantry unit (apart from other targets).

Increase Distance as needed.

Select a terrain where you can see straight across up to 300m or with a slight inclination even.

To achieve the most intriguing results, make sure the unit goes prone (leg shot) on your first shot.

Note:
M107 is deadly single hit even on body hits.
At 800m do kill with a headshot.

Sample mission:
http://www.youtube.com/watch?v=bs0L0RJmKSg

0001.jpg (103.2 kB) kju, 07/26/2010 08:02

0002.jpg (79.3 kB) kju, 07/26/2010 08:02

0003.jpg (45.7 kB) kju, 07/26/2010 08:02

Projectile_Penetration.Desert_E.7z (3.3 kB) kju, 07/26/2010 08:02

Projectile_Penetration.utes.7z (1.7 kB) kju, 07/26/2010 08:02

TargetRange.Desert_E.zip (13.7 kB) Fireball, 10/05/2010 06:15

11479_EAST.desert_e.7z (1.3 kB) kju, 10/13/2011 14:47

11479_WEST.desert_e.7z (1.3 kB) kju, 10/13/2011 14:47


Related issues

related to A.C.E. for OA - Bug #10611: Bullet Damage For Snipers Rejected 05/12/2010
related to ARMA2 Community Issue Tracker - Bug #8285: Grass layer doesn't lower "fire LOD" on infantry In progress 01/19/2010 12/01/2010
related to ARMA2 Community Issue Tracker - Feature #14151: Penetration improvement Assigned 10/03/2010
related to ARMA2 Community Issue Tracker - Bug #23553: Infantry weapon model blocks bullets, shields infantry as... Assigned 08/18/2011
related to ARMA2 Community Issue Tracker - Feature #13587: Increase 5.56 rounds damage. Assigned 09/09/2010
related to A.C.E. for OA - Bug #17316: 5.56 doesn't do enough damage at distance (~300m) Closed 02/04/2011 08/31/2011
related to ARMA2 Community Issue Tracker - Bug #20441: Units when prone take only halve the damage Closed 06/16/2011
related to ARMA2 Community Issue Tracker - Bug #25292: bullets velocities are too slow Rejected 10/09/2011 10/24/2011
duplicated by ARMA2 Community Issue Tracker - Feature #4300: Bullet damage reduced too much over distance Duplicate 09/06/2009 09/16/2010
duplicated by ARMA2 Community Issue Tracker - Feature #3722: Soldiers are not hurt enough in limbs, bullet does not pe... Duplicate 08/18/2009

History

Updated by Moerderhoschi over 4 years ago

  • File mission.sqm added
  • File ownbox.sqf added

Updated by rye over 4 years ago

I had this bug on the original Arma 2. I complained to ACE about it, they said it was the BIS hitpoint system. #10611

Tends to only do it with 7.62mm snipers.

Updated by rye over 4 years ago

JFK reloaded has more of an idea on projectile ballistics and penetration ability.

When the bullet hits it doesn't go straight into the target and straight back out...at long distances. Because of the angle of the bullet the projectile actually would penetrate from above the target and come through on top of the target; most probably ripping through the centre mass, main area of organs and causing maximum damage.

In A2 all you seem to get is, bullet hit, in and out of the target. Target still moving and still taking TOO MANY bullets to go down.

Even if you hit the target in the face/head, I've seen some of them live. Even in a fatal shot of the T intersection of the face, between the eyebrows and going down to the mouth creating a T symbol.

Therefore the BIS hitpoint system is wrong. Terminal and Wound ballistics have to be taken into affect: the crush factor and the tear factor should be main priorities, so should be exit and entry wound sizes for rate of bleeding. Of course, this is hard to replicate in game but the hitpoint system must then be improved to make it more realistic on sniping.

Updated by rye over 4 years ago

List of issues:
Bullet effectiveness on target at long distances is too weak (damage/hitpoint system).
Penetration ability of bullets.

If your ballistics (including effect on target) are wrong, then real life calculations and abilties will be off.

Updated by kju over 4 years ago

  • File 0001.jpg added
  • File 0002.jpg added
  • File 0003.jpg added
  • File Projectile_Penetration.Desert_E.7z added
  • File Projectile_Penetration.utes.7z added
  • Subject changed from Projectile Penetration to Bullets loose too much power over distance - especially even sniper need 3-4 body hits on distance.
  • Due date set to 10/01/2010
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from Please select... to 1.53 BETA
  • Difficulty changed from Not set to Veteran
  • Reproduced by another DH user changed from No to Yes
  • I am using set to OA only
  • Reproducible for you changed from No to Yes

Updated by kju over 4 years ago

  • File deleted (ownbox.sqf)

Updated by kju over 4 years ago

  • File deleted (mission.sqm)

Updated by Fireball over 4 years ago

  • File TargetRange.Desert_E.zip added
  • Subject changed from Bullets loose too much power over distance - especially even sniper need 3-4 body hits on distance. to Bullets loose too much power over distance

Updated description with my repro videos and test results, attached my mission (Target Range) used to repro the issue.

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Updated by kju about 4 years ago

  • Due date changed from 12/01/2010 to 03/01/2011
  • Affected ArmA II version changed from 1.55 BETA to 1.58 BETA

Updated by kju almost 4 years ago

  • Due date changed from 03/01/2011 to 07/01/2011
  • Category changed from Gameplay to Weapons
  • Affected ArmA II version changed from 1.58 BETA to 1.60 BETA
  • CPU deleted (DualCore E6850)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Updated by Nyles over 3 years ago

With the recent awesome decrease of units warping over distance, this issue becomes more of a problem again now that players can more reliably engage and hit targets over distance.

Please review damage drop over distance and tweak in favor of gameplay. To my understanding, ArmA is all about making it challenging to hit enemies through large view distances, gun recoil and a proper ballistic simulation. Therefore, if a hit has been achieved, make sure there is satisfying reward for the player. Ideally this would be a terminal (or at least noticably severe) effect on the target.

Also, headshots (or hits that read as such, incl. bloody face effect, etc) should be terminal at any distance.

Updated by kju over 3 years ago

Damage table

Distance Damage SCAR L STD HOLO Speed in m/s Damage M110 TWS
50 0.60 1000
100 0.52 1000 1.23
150 0.45 893 1.16
200 0.39 844 1.02
250 0.34 768 0.92
300 0.29 775 0.84
350 0.25 742 0.76
400 0.22 698 0.70
450 0.63
500 0.58
600 0.45
700 0.39
800 0.33

From what I recall Fireball and me testing the speed reduction is correct.
The question is how the current relation of speed to damage is done and if it is correct.
Or if it is another element to influence this.

Updated by Fireball over 3 years ago

  • Subject changed from Bullets loose too much power over distance to Bullets do not enough damage over distance

Updated by Suma over 3 years ago

The relation of damage to velocity should be linear, i.e. half velocity should cause half damage (this assumes the damage is proportional to momentum). We have also considered quadratic (damage proportional to energy), but this led to a damage reduction which was too extreme (half velocity resulted in 1/4 damage).

However, your table seems to indicate the end effect ingame does not match the intended behaviour. Can you create a very simple repro which would show the problem (just two AI units, one firing at the other, where the impact is known to be weaker then expected)?

Updated by kju over 3 years ago

Suma have a look if you find these useful:

Obs
The AI tries to kill a target at 500m distance.
By default the mission use SVD and M110.
Most of the time the first hit is not lethal.

Exp
I would guess they should be lethal on body/head hit.

Repro
  1. Editor
  2. Start
  3. Watch
  4. In the chat and rpt you see HD logging
  5. Also fired and killed event displayed for better overview
  6. The target AI is spawned again when dead
Notes
  1. In the NG in general at the very end, there is a very relevant discussion in terms of typicalSpeed influence ([Question] Is typicalSpeed still used (cfgAmmo) value?)
  2. The target is forced to stand. So no damage reduction from prone target.
  3. M107 and KSVK are mostly deadly with one hit on that distance.
  4. However for heavy sniper there is quite a range up to 8x the taken damage.
  5. So rather inconsistent damage received (hard to estimate the actual impact area though - if that matters aside from body vs head).
  6. While the SVD damage is very consistent.
  7. Change the unit to test with a different weapon.
  8. Move the target unit (and WP for distance shown) closer to test with lower distance.
rpt logging
weapon ammo hit initSpeed
KSVK B_127x108_Ball 30 850
SVD B_762x54_noTracer 12 870
AKS_74_GOSHAWK B_545x39_Ball 8 900
M107 B_127x99_Ball_noTracer 26 850
M110 B_762x51_noTracer 12 900
M40A3 B_762x51_noTracer 12 900

Updated by kju over 3 years ago

This might be relevant if true:
http://community.bistudio.com/wiki/Weapons_settings

typicalSpeed=900; // speed at 100% hit (m/s)

hit=20; // damage done on impact at typical speed, modified by actual speed depending on explosion coef.

For ArmA we used as help 
FMJ bullet energy hit = sqrt(weight/2)*speed/5 
This works for small arms fire,....
First using of this equation was in ČSLA 2.2 for OFP. In BI games is since ArmA 1.05.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

I think I have found the underlying cause and fixed it in 85440 (the speed factor incorrectly influenced the hipoint computation twice, once for hit value, second time for distance), and the damage values seem now correct when debugging, however I am not sure the observed behaviour is what you expect. SVD still most often requires 2 hits at 500 m distance, while M107 kills with one hit. Once available, please, test and comment on the result.

Updated by kju over 3 years ago

Thanks Suma!

I think the main problem is the overall player perception of potential issues:

"Why do infantry need 3-5+ hits at distance"
"At close range I can kill with 1 or 2!"
"How comes a sniper hit in the body does not instant kill"

Therefore most important was to sort the "halving damage when prone" issue.

I think this one (speed/velocity to damage translation) is still only the 3rd most important here.

Second most important is this one:

#23553: Infantry weapon model blocks bullets, shields infantry as no/very little subsequent damage gets applied

This happens way too often and people cannot see the idea of it.
That's why they think something is wrong.

As for this issue we have to accept that the game uses a system of hitpoints
and damage applied based on speed/velocity to typicalSpeed along with the
somewhat "artificial" representation of hit damage per bullet type.

One could make a more complex system, like ACE does, however this is outside
the scope of this ticket and arma 2.


So again I think this fix here is useful, but #23553 should be looked into as well.

Updated by kju over 3 years ago

  • Due date deleted (07/01/2011)
  • Target version set to 1.60 BETA

Updated by Sickboy over 3 years ago

We like the improvements over distance, but it seems overall there is much higher damage now.
For some notes see related tickets: #25843

I suppose it just comes down to accounting for the engine fixes/changes.

Updated by kju over 3 years ago

Much higher?

2-5% according to that anon guy? Hardly much and not really useful feedback in that form.
This ticket needs some detailed testing with numbers as done in this ticket above.

In the BI forum there was a lot of feedback and the vast majority was very positive.
That said I believe they mostly actually meant the "1/2 damage when lying" removed...

Updated by Sickboy over 3 years ago

5-10% according to http://dev-heaven.net/issues/25843#note-2
But you are correct, "much" is exaggerated. Still significant enough to change balance of body armor, etc.
But as said I suppose this is simply something we will have to look into from our end.
Still I wonder if BIS armor settings etc were setup with lower power etc in mind, and thus not balanced anymore now.

I dunno if it's easy to redo your info tables based on latest betas?

Updated by kju over 3 years ago

So again without proper feedback the whine or praise of people is mostly useless.
(and mostly about not this change/fix)

Updated by Sickboy over 3 years ago

  • Assignee changed from Dwarden to Suma

According to http://forums.bistudio.com/showthread.php?p=2048549#post2048549
The latest beta might have new changes onboard with damage over distance, or damage when prone; http://forums.bistudio.com/showthread.php?p=2048549#post2048549

Suma; Were there changes to the damage handling again in this latest Beta, if so, could you please share details? Thanks!

Updated by Suma over 3 years ago

  • Assignee changed from Suma to Dwarden

Please, never assign me suspections, only confirmed reports with a proper repro.

Were there changes to the damage handling again in this latest Beta

No. If they were, I would describe them. I try hard not to do any changes silently.

Updated by Sickboy over 3 years ago

Thanks and Point taken.

Updated by admin over 3 years ago

Removed offtopic comments by kotov.

Kotov you are best to make your comments in the BI forum.
The CIT is certainly the wrong place for you.

Updated by Dwarden over 3 years ago

  • Status changed from Resolved to Closed

closing as fixed...

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF