Bug #10993

[70951] ExecVM a Zero Byte File causes Arma to Freeze with -exThreads=3

Added by ViperMaul almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:06/03/2010
Priority:High Due date:
Assignee:Dwarden % Done:

100%

Category:Game freezes
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

It took me some time to trace this down to a single line of code in the mod.
I know this will sound silly but who knows what other situations the source of this bug could sneak into after the release of the patch and OA.

STEPS TO REPRODUCE:
  1. Create a zero byte ZeroByteFile.sqf
  2. Add the line [] execVM "ZeroByteFile.sqf"; in the init.sqf or some part of your mod somewhere.
  3. Run your beta [70313] or later using -exThreads=3

RESULTS:
Arma2 Freezes without any dump files.

I guess the intention by the developer was to disable some feature by deleting the contents of a .SQF file rather then commenting the line the calls it.

I attached a mission that will help testing each of the -exThreads parameters.
-exThreads= 0|1 do not cause this problem. Haven't tested the 5|7 parameters yet.

ZeroByteFileTest.rar - Test Mission that Triggers an ARMA2 freeze with -exThreads=3 (1.9 kB) ViperMaul, 06/03/2010 20:26


Related issues

related to ARMA2 Community Issue Tracker - Bug #11172: Gamefreeze with Minplayers greater than 1 Closed 06/12/2010
duplicated by ARMA2 Community Issue Tracker - Bug #13325: execVM "emptyfile.sqf" causes game to freeze Duplicate 08/28/2010
duplicated by ARMA2 Community Issue Tracker - Bug #13743: execVM + empty script = freeze Duplicate 09/17/2010

History

Updated by Dwarden almost 5 years ago

  • Assignee set to Dwarden

Updated by ViperMaul almost 5 years ago

  • Assignee deleted (Dwarden)

Typo
-exThreads= 0|1|2

Should read
-exThreads= 0|1

Again these do not fail under these conditions. Only -exThreads=3
It would be interesting to see the results for 5 and 7

Updated by kju almost 5 years ago

  • Due date set to 09/03/2010
  • Category set to Game freezes
  • Status changed from New to Assigned
  • Assignee set to Dwarden

Updated by kju almost 5 years ago

Well done to trace this ViperMaul!

Thank you.

Updated by ViperMaul almost 5 years ago

Just tested the latest beta [71141]

-exThreads=0 - passed.
-exThreads=1 - failed. Arma Freezes
-exThreads=3 - failed. Arma Freezes
-exThreads=5 - failed. Arma Freezes
-exThreads=7 - failed. Arma Freezes

NOTE:
If the test passes, then try to alt-tab out for a few seconds. Then try to alt-tab back.
Alt-Tab may be a separate bug.

All tests run in a window.

Updated by ViperMaul almost 5 years ago

[71213] produces the same freeze results.

Updated by Dwarden almost 5 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by ViperMaul almost 5 years ago

Issue persists in [71275]

Updated by ViperMaul almost 5 years ago

Issue persists in [71382]
Again no crash logs are produced.

Updated by kju almost 5 years ago

  • Due date changed from 09/03/2010 to 07/10/2010

ty

Updated by Dwarden almost 5 years ago

  • Target version set to Upcoming version

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.06 BETA to 1.52 BETA
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

still in latest OA

Updated by Dwarden over 4 years ago

  • Status changed from Assigned to In progress
  • % Done changed from 0 to 10
  • Affected ArmA II version changed from 1.52 BETA to 1.53 BETA
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju over 4 years ago

  • Due date changed from 07/10/2010 to 08/01/2010

Updated by Dwarden over 4 years ago

  • Priority changed from Normal to High

Updated by ViperMaul over 4 years ago

Still happens in 1.54 + beta.
We lost about an hour tying to isolate a MOD freeze thinking it was a mod problem.
The developer should not have called an empty SQF. But he accidentally did.
My concern is if the engine freezes with this type, it may freeze for other reasons depending on the type of bugs.

Updated by Dwarden over 4 years ago

still WIP

Updated by Fireball over 4 years ago

  • Due date changed from 08/01/2010 to 12/01/2010

Updated by Fireball over 4 years ago

  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

Updated by Dwarden over 4 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 10 to 100

shall be gone since b73126

Updated by kju over 4 years ago

  • Due date deleted (12/01/2010)
  • Target version changed from Upcoming version to 1.55 BETA

Please confirm.

[73126] Fixed: execVM with a zero sized file has freezed the game.

Updated by ViperMaul over 4 years ago

Comfired fixed on my system.
Beta test was [73311] client
Thank you Dwarden and BIS.

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

ty

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF