Bug #10934

MHQ deploys at (1,1)

Added by takbal almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:05/31/2010
Priority:Normal Due date:
Assignee:Benny % Done:

100%

Category:-
Target version:Warfare BE 2.061
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:

Description

It regularly happens that the MHQ deploys at (1,1), especially when the server is heavily loaded towards the end of a game and starts lagging. Although it was already reported in

http://dev-heaven.net/issues/8077
http://dev-heaven.net/issues/5218

it is still an issue on 2.060, our commander experienced it on a public server yesterday. It is probably related to relatively rapid re-deployment of the MHQ, but the lag looks necessary as I could not reproduce it on a LAN server.

Fix suggestion: Construction_HQSite.sqf should be protected against multiple parallel calls with a mutex; probably what is happening is that the previous execution of it is still running while the second is called, and the temporary [1,1,1] position is used as an input for the second call. At a minimum, the temporal location should be changed to some more viable position, where the MHQ can be easily saved from if it happens.

It is a game ruining bug and happens relatively frequently, about once in each five-ten games.

History

Updated by takbal almost 5 years ago

Also happened today. Definitely fast deploy/undeploy problem.

Updated by Benny over 4 years ago

  • Priority changed from High to Normal

Updated by Benny over 4 years ago

  • Status changed from New to Closed
  • Assignee set to Benny
  • Target version changed from Warfare BE 2.060 to Warfare BE 2.061
  • % Done changed from 0 to 100

Added a script handler.

Also available in: Atom PDF