Feature #10904

Increase max number of units for player teams

Added by CptBBQ almost 5 years ago. Updated over 4 years ago.

Status:Closed Start date:05/30/2010
Priority:Normal Due date:
Assignee:Benny % Done:

100%

Category:-
Target version:Warfare BE 2.061
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:

Description

Speaking for the coop gamer, single player and few player crowd here:

I don´t see a problem increasing the max limit to something like 64, maybe even more. The game already supports huge team sizes, so it should be up to the server´s admin to decide how many units it can handle at the given number of players.

After all, it´s just a parameter =)

History

Updated by Benny over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Benny
  • Target version set to Warfare BE 2.061

Updated by kanelbolle over 4 years ago

CptBBQ wrote:

Speaking for the coop gamer, single player and few player crowd here:

I don´t see a problem increasing the max limit to something like 64, maybe even more. The game already supports huge team sizes, so it should be up to the server´s admin to decide how many units it can handle at the given number of players.

After all, it´s just a parameter =)

The idea is good, i have tryed my self to modify this in warfare but the server laggs to much bacause the AI must be aktive on player slots for this to work, in 2.056 anyhow.
Only thing i see making this possible like Berzerk missions up to 100 players is to remove the AI entirely in a parameter.
But as i said this caused frequent lagg evert 4-5 sec when AI was removed from player slots. Benny might have a clue how to do this without the lagg.

Updated by CptBBQ over 4 years ago

I think I don´t get your point (or maybe you misunderstood the intention of this ticket?).

This issue is not at all about the number of people able play on a server simultaneously. It´s about the maximum number of bots a single player can buy to join his team. This limit can already be exceeded by ordering paratroopers.

Server performance (although I stated differently above) shouldn´t be an issue at all because those bots are handled by the client.

I don´t see how AI teams should be influenced since there´s already a separate parameter controlling their max unit number.

Although, I´ve got to admit that I don´t have much experience with modding and as far as I can tell, what Benny´s doing with Warfare is bordering on sheer magic - so yeah, anything´s possible.

And maybe I just didn´t understand what you were trying to say^^

Cheers,
BBQ

Updated by INNOCENTandCLUELESS over 4 years ago

I made a similar suggestion, I would rather define and count the total amount of AI bots + humans per side.

Example: Allow 300 units per side regardless if 30 teams with 9 team-AI + human player or 10 teams with 29 AI + human.

May allow 400 so the comm and squad members can spread another 100 AI in several static defenses.

Problems:

- How to count units in vehicles
- GUI required to move units between squads

Updated by Benny over 4 years ago

  • Status changed from Assigned to Closed

Updated by Benny over 4 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF