Bug #10602

*G* Effects Blackout problems

Added by Sickboy about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:05/11/2010
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:Script
Target version:1.2
Component:sys_g_effects Affected Version:
Close Reason:

Description

2 Reported issues:

Associated revisions

Revision b29ae60e
Added by Xeno about 5 years ago

MP g effects problems fixed, refs #10602

Revision 4391aa84
Added by Xeno about 5 years ago

G effects reduced when afterburner is on, refs #10602

History

Updated by Sickboy about 5 years ago

  • Subject changed from Blackout problems to *G* Effects Blackout problems

Updated by VKing about 5 years ago

I've noticed problems related to the G effects blackouts as well, and attempted to find out under what circumstances it happens.
I haven't had much luck, but I'm reasonably certain of the following:

Note that I've noticed and tested this primarily on a dedicated server. I haven't noticed any problems in singleplayer (yet). The following statements refer to MP testing on a dedi server.
  1. Blackouts sometimes appear to occur at random while flying.
  2. Blackout behaviour in MP as a pilot (i.e. with crewprotection) sometimes appear to mimic normal blackout behaviour in SP as a unit without crewprotection.
  3. Blackouts sometimes appear to occur if a different player flying at the same time pulls a manouver that would cause a blackout.
  4. Blackouts sometimes occur very quickly (instantly) and then disappear very slowly (several minutes).
  5. Blackouts sometimes occur while flying in a straight line/other manouver without heavy G-forces.
  6. Sometimes the screen becomes blurred instead of black.

These are all observations noted during testing. I haven't been able to reliably reproduce any of them under specified circumstances, as they appear to occur randomly at random frequencies.

Updated by VICTIM913 about 5 years ago

I have also had problems. I love flying and I can't fly anything without blacking out. If I fly straight under 300mph I am ok, but if i go over that speed and start any simple turn i start to black out. I read the pbo and it says pilots shouldn't black out. But I only use pilots. I can't ever seem to really get the blackout to completely go away. It takes me miles to make any kind of a turn in a harrier at slow speed. I would have to fly all of Chernarus in order to turn without completely blacking out. Even when diving to attack.

Updated by Sickboy about 5 years ago

Didn't animalmother have "the" solution to all these problems? I'd be glad to implement it if it were a complete solution.

Updated by Xeno about 5 years ago

Actually with animalmothers formula the effects were even worse, that's why they aren't implemented yet :)

No idea if somebody has changed it while I wasn't there.

Updated by Xeno about 5 years ago

I've done various tests now (dedicated and in the editor), no problems, worked as expected.

Probably some other mission oder addon scripts cause time slice problems ?!?

Btw, VKing, the system runs only locally on each client and is checking for the player object if he is in the plane, so other players can't ifluence it.

But probably it is again our friend engineOn EH.

Updated by Xeno about 5 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 50

Should be better now, engine EH now fires only where the plane is local and a global EH broadcasts it to all other clients.

Updated by Sickboy about 5 years ago

  • Assignee set to VKing

Nice one Xeno.
I suppose we'll have to wait until after Friday for VKing feedback? :D

Updated by VKing about 5 years ago

After testing with zGuba it looks like the system works much better.
  • zGuba had some insta-blackout because of using the afterburner and then lagging out, possibly leading the script to think he was going a lot faster than he was.
  • zGuba reported having some blackout when I pulled Gs in another plane, but we weren't able to reproduce it.
  • Crewprotection seems to work properly again.

No other problems or observations that I remember.

Updated by zGuba about 5 years ago

VKing wrote:

  • zGuba had some insta-blackout because of using the afterburner and then lagging out, possibly leading the script to think he was going a lot faster than he was.

Yup, afterburner causes warping.

Updated by Xeno about 5 years ago

Beside the afterburner...

engineOn EH shows some weird behaviour since 1.05 or a previous beta patch. It returns the correct on or off state only where the vehicle is local (in MP). We had the same problems with helidust, it suddenly didn't work anymore allthough nothing changed. After switching to engineOn EH local check and broadcasting the state with an event to the other clients it was fine again.

Updated by Sickboy about 5 years ago

Nice work all involved, let's see how it turns out after the update!

@Xeno: it's probably time we add a single EngineOn event as opposed to multiple? :P

Updated by Sickboy about 5 years ago

  • % Done changed from 50 to 70

Updated by Xeno about 5 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from VKing to Xeno
  • % Done changed from 70 to 100

Closed for now. I've added some code that reduces g effects when the afterburner is activated.

Pleas create a new ticket if there are new issues.

Also available in: Atom PDF