Bug #10559

-name with -profile mixes paths of configuration files and modfolders

Added by alef about 5 years ago. Updated almost 4 years ago.

Status:Assigned Start date:05/08/2010
Priority:Normal Due date:12/15/2010
Assignee:Dwarden % Done:

0%

Category:Startup parameters
Target version:-
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Rep
  • Give the following command line arguments:
    -profiles=C:\DIR -name=name -mod=mod
Obs
  • arma2oa.exe process will not resolve mod as C:\DIR\Users\name\mod\addons but as C:\DIR\Users\alef\mod\addons where alef here is the system user name.
  • ArmA2OA.cfg is in alef\ instead that in name\ subdir of Users, while the NAME.ArmA2OAProfile is correctly used under name\

History

Updated by Fireball about 5 years ago

  • Status changed from Assigned to Feedback

This sounds like a good idea to look in existing profile folders - there is no reason why the directory with "name" (which you specified) should exist.

Updated by alef about 5 years ago

Links: -profiles parameters

Another example:
-profiles=D:\my_arma2_profiles -name= CIT -mod= MyMOD
will use
D:\my_arma2_profiles\Users\ CIT \CIT.arma2profile
and search for
C:\Programs\BI\ArmA2\ MyMOD
D:\my_arma2_profiles\Users\ alef \ MyMOD

Updated by Fireball about 5 years ago

  • Status changed from Feedback to Assigned

-name behaves differently when used with -profile

Thanks for the clarifications.

Updated by kju almost 5 years ago

  • Subject changed from [70184] modfolder with -profile and -name to [70184] modfolder with -profiles and -name
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju almost 5 years ago

  • Due date changed from 05/23/2010 to 10/01/2010
  • Status changed from Assigned to Feedback

Still true in OA?

Updated by alef almost 5 years ago

[73311] Yes. And now also the cfg is broken.

Running

E:\arma2>Expansion\beta\arma2oa.exe -profiles=E:\temp -name=CIT -mod=MOD

with an empty E:\temp.

From ProcMon:

Date & Time:    19/09/2010 16.29.21
Event Class:    File System
Operation:    WriteFile
Result:    SUCCESS
Path:    E:\TEMP\Users\alef\ArmA2OA.cfg
TID:    3652
Duration:    0.0000278
Offset:    0
Length:    77

Date & Time:    19/09/2010 16.29.21
Event Class:    File System
Operation:    QueryOpen
Result:    NAME NOT FOUND
Path:    E:\TEMP\Users\alef\MOD
TID:    3652
Duration:    0.0000051

Date & Time:    19/09/2010 16.29.30
Event Class:    File System
Operation:    WriteFile
Result:    SUCCESS
Path:    E:\TEMP\Users\CIT\CIT.ArmA2OAProfile
TID:    3652
Duration:    0.0000282
Offset:    0
Length:    143

Updated by kju almost 5 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.06 BETA to 1.55 BETA

Updated by alef almost 4 years ago

  • Subject changed from [70184] modfolder with -profiles and -name to -name with -profile mixes paths of configuration files and modfolders
  • Description updated (diff)
  • Due date changed from 12/01/2010 to 12/15/2010
  • Affected ArmA II version changed from 1.55 BETA to 1.60 BETA

Updated by kju almost 4 years ago

  • Category changed from Game settings to Startup parameters

Also available in: Atom PDF