Bug #10491

Black screen through contusion can be canseled by pressing "Esc"

Added by conKORD about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:05/05/2010
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:Script
Target version:1.2
Component:ace_sys_wounds Affected Version:
Close Reason:

Description

Mission example is attached.
Note: hit by Metis not every time puts player in contusion, if it's not appeared restart the mission.

With this bug I can exit tank while I am in contusion and simply kill Metis operators.

No any 3rd party mods, last version of ACE (but version is no matter, bug exist from long time ago).

contusion_test.utes.zip (764 Bytes) conKORD, 05/05/2010 15:35

Associated revisions

Revision 935f6afd
Added by Xeno about 5 years ago

Faster check for unconscious units who got ejected from a vehicle. They could run around for a few seconds before falling on the ground, refs #10491

History

Updated by Sickboy about 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Xeno
  • Target version set to 1.2

Updated by Xeno about 5 years ago

Do you mean that units in a tank don't fall unconscious when a tank gets hit by a Metis ?

If so then it's probably a sys vehicledamage problem (tested the attached mission yesterday, nothing happened).

The other bug is allready fixed but didn't make it in 1.1

Updated by conKORD about 5 years ago

Xeno wrote:

Do you mean that units in a tank don't fall unconscious when a tank gets hit by a Metis ?

No. Its only about player.

If so then it's probably a sys vehicledamage problem

It happened sometime when I was out of vehicle and contused by explosion. Tank in example is only because contusion in vehicle easier to reproduce.

(tested the attached mission yesterday, nothing happened).

Metis not every time puts player in contusion. Sometimes he destroy tank, sometimes nothing happens after hit. If in first 5 second you are not in contusion - restart the mission. If you are in contusion - black screen can be canceled when mouse cusor appears.

Step by step:
1)Start mission
2)If in first 5 seconds hits by metis did not put player in contusion - restart the mission.
3)When mouse cursor appears press "esc"
4)You have about 3 seconds to exit damaged tank.
5)Black screen returns.
6)Wait until mouse cursor appears again and press "esc".
7)You have about 3 seconds to kill Metis operators.
8)If this time is not enough to kill them - go to step 5.

The other bug is allready fixed but didn't make it in 1.1

Which bug? I think you not understood about what I wrote.

Updated by Xeno about 5 years ago

Hm, can you check again with the latest update ?

Updated by conKORD about 5 years ago

I can't update today. I'll check it tomorrow.

Updated by conKORD about 5 years ago

All the same, nothing changed. Bug still exist.

Updated by Xeno about 5 years ago

If I just could reproduce it which I simply can't.

Updated by conKORD about 5 years ago

I don't know what can help you to reproduce it. Maybe I should capture video of it and share on youtube?

Updated by Xeno about 5 years ago

Yes, probably it helps.

Updated by conKORD about 5 years ago

http://www.youtube.com/watch?v=IdtGCDVibf8

Esc pressed at 0:07 0:12 0:17 0:26 0:36 0:45 0:59 1:03
Indicator - mouse cursor

Updated by Xeno about 5 years ago

  • Category set to Script
  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Should be really fixed now.

Also available in: Atom PDF