Bug #10266

TS3 port setting ignored when not using "Nickname" parameter (TS3 doesn't like extra '&')

Added by doolittle about 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:04/23/2010
Priority:Normal Due date:
Assignee:Yoma % Done:

100%

Category:Server
Target version:2010_04_24 1.0.61 Beta

Description

Using 1.0.60.0

Teamspeak tab -> TS port ... setting to 9994 but always connects to port 9987??

History

Updated by Yoma about 5 years ago

Could the TS port in your case be set by the server itself and be outdated in the autoconfig.7z file?
(you set value to x, check for addons, value is set to y)

Updated by doolittle about 5 years ago

This is Server.xml

<?xml version="1.0" standalone="yes"?>
<DSServer xmlns="http://tempuri.org/DSServer.xsd">
  <Server>
    <AddonPwd />
    <AddonURL>http://www.7-75th.com/updater/updater.7z</AddonURL>
    <AddonUserName />
    <AutorunTS>false</AutorunTS>
    <GameIP>gs.7-75th.com</GameIP>
    <GamePort>2310</GamePort>
    <GamePwd />
    <HomePage>http://www.7-75th.com</HomePage>
    <Name>7th Ranger Battalion</Name>
    <TSAnonimous>true</TSAnonimous>
    <TSChannel />
    <TSChannelPwd />
    <TSIp>ts3.7-75th.com</TSIp>
    <TSNickname />
    <TSPort>9994</TSPort>
    <TSPwd />
    <TSUser />
    <TSVersion>TS3</TSVersion>
    <Version />
    <Game>arma2pc</Game>
    <RequiredAddons />
    <OptionalAddons />
    <MessageOfTheDay />
  </Server>
</DSServer>

Go to TeamSpeak tab, click "Test TS" ... connects to 9987, not 9994

<14:08:09> Trying to resolve hostname ts3.7-75th.com
<14:08:09> Trying to connect to server on ts3.7-75th.com:9987
<14:08:12> Connected to server: TeamSpeak ]I[ Server
<pre>
<14:08:12> Welcome to TeamSpeak, check www.teamspeak.com for latest infos.
</pre>

Updated by Yoma about 5 years ago

  • Category set to Server
  • Assignee set to Yoma

There was a trailing

&

that caused TS3 not to use the default TS3 identity when not setting your nickname.
Solved in next version.
Tnx for reporting.

Updated by Yoma about 5 years ago

  • Status changed from New to Resolved
  • Target version set to 2010_04_24 1.0.61 Beta
  • % Done changed from 0 to 100

Updated by Yoma almost 5 years ago

  • Subject changed from TS port setting ignored? to TS3 port setting ignored when not using "Nickname" parameter (TS3 doesn't like extra '&')

Updated by Yoma almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF