Feature #10121

DAGR GPS

Added by rosuto over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:04/16/2010
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:Conversion
Target version:1.2
Component: Affected Version:
Close Reason:

Description

I've been working on a DAGR GPS that works soley with ACE. A preview video can be found at: http://www.youtube.com/watch?v=rfCEo3gVMSE

The DAGR itself is nearly completed, but I am having an issue changing the addaction into an addKeyHandler event. I want to use shift + whatever key is set to open the DAGR to open up the DAGR menu, but it fails to work. I know that ACE uses its own function to handle keys, but its a bit above what I can understand. If someone can help me figure out the addKeyHandler or the way ACE handles keys, then I could complete this addon and push it out to whoever wants it.

Heres the piece of code I am using:

#include "\userconfig\GPS_DAGR\GPS_DAGR.hpp"

waitUntil{!isNull player};
if (local player) then {
player setVariable ["DAGR_RUN",false,false];
player setVariable ["DAGR_STP",false,false];

DAGR_WP_NUM = 0;  //number of WP entered into DAGR
DAGR_WP0_String = "";
DAGR_WP1_String = "";
DAGR_WP2_String = "";
DAGR_WP3_String = "";
DAGR_WP4_String = "";
DAGR_WP0 = 0;
DAGR_WP1 = 0;
DAGR_WP2 = 0;
DAGR_WP3 = 0;
DAGR_WP4 = 0;
DAGRSLEEP = 0.5;
EMPTYVECTOR = true;
DAGR_DISPLAY_SELECTION = "DATA";
[_optActKey, [false, false, false], {player execVM "GPS_DAGR\DAGR_START.sqf"}] call CBA_fnc_addKeyHandler;
[_optActKey, [true, false, false], {player execVM "GPS_DAGR\DAGR_MENU_INIT.sqf"}] call CBA_fnc_addKeyHandler;
null = [] execVM "GPS_DAGR\DAGR_VECTOR.sqf";
};

It doesn't cause any errors or halts, but hitting shift + _optActKey doesn't do anything.

History

Updated by fireship4 over 5 years ago

Looks very good, thank you.

Updated by VKing over 5 years ago

This looks excellent! Keep it up :)

Updated by PeaceDoctor over 5 years ago

Awesome!

Updated by CarlGustaffa over 5 years ago

Sweeeeeeeet! :) Is it possible to have the old style "GPS Map" thingy available only in vehicles that have it, and this new one for infantry?

Updated by JDMT over 5 years ago

That has got to be the most awesome thing I've seen in a long time.

Updated by arye_r over 5 years ago

Great job!!!

Updated by rosuto over 5 years ago

As of right now, both GPSs are still avaiable and you can carry both if you want to. In the future, this might change if I figure out how to integrate a custom minimap into the DAGR, which would then be followed by a vehicle GPS system such as the FBCB2 or Blueforce Tracker.

Updated by Nou over 5 years ago

  • Category set to Conversion
  • Status changed from New to Assigned
  • Assignee set to Nou
  • Priority changed from Low to Normal
  • Target version set to 1.1
  • % Done changed from 0 to 30

Alright, Rosuto is going to contribute this and I will be working to integrate it into ACE2. Awesome! :D

Updated by Nou over 5 years ago

  • Tracker changed from Support to Feature

Updated by CarlGustaffa over 5 years ago

Naturally I won't object to a decent DAGR, incl moving map capability. But how about the PLGR? I might want to give the DAGR to key personell, and let others only get the PLGR. Or have them in limited supply. Whatever the mission dictates in order to make it more realistic, for game balancing issues, or simply to raise the challenge for some.

By giving them the PLGR (no map, and planning purposes doesn't have to be included either, just the basic old OFP style GPS 6-digit grid readouts), I can "allow" players to "have brought their civilian GPS", without the improved accuracy the military version would provide. Navigational features are nice, but in the typical Arma2 game world and missions (battlefield size), I don't think they would be very much needed for the typical infantry. Map and compass for basic navigation, but with the readout to get people started. Without knowing what grid they are in (they should, but skills vary), picking out features on the map can be a tedious task.

I'm not sure if the DAGR has yet fully replaced the PLGR either, has it? In all branches and armies?

PLGR: http://www.milspec.ca/canforce/gps/plgr96.html

http://en.wikipedia.org/wiki/Precision_Lightweight_GPS_Receiver
"despite being superseded by the DAGR, large numbers remain in unit inventories and it continues to be the most widely used GPS receiver in the US military"

DAGR: http://www.rockwellcollins.com/ecat/gs/DAGR.html?smenu=104

http://en.wikipedia.org/wiki/Defense_Advanced_GPS_Receiver
"GPS receiver known as the "Polaris Guide", that looks like a DAGR, but uses only the civilian C/A code signals"

Updated by S2 over 5 years ago

Yeah, we don't use the PLGR anymore. At least when i was in Iraq from 06 to 08, all we used was the DAGR.

Rosuto has worked very hard on this really nice DAGR, and I think what he has provided should be enough to keep most of us happy.

The PLGR is a POS anyways, it would only be realistic if it didn't function 80% of the time.

Updated by CarlGustaffa over 5 years ago

Lol, 80%, that bad? Maybe they keep them in stock in order to force learning navigation the old fashion way :)
I'm not happy about the DAGR... I'm ecstatic :) But in some missions it might be slightly overkill, i.e. in "historic missions". But no biggie, I can easily give coordinates in a separate window if I need to.

Updated by rosuto over 5 years ago

The DAGR in no way replaces the default GPS and acts like any other personnel item in game. Hence it can be removed from maps entirely or just given to specific people. And if you really want to screw with people, ie pretend the DAGR is being jammed, you can put in the wrong map code to give false Y coordinates.

Updated by Nou over 5 years ago

  • Target version changed from 1.1 to 1.2

With 1.1 pushed up now, this will not be ready in time, though it should be shortly after and appear in the regular updates and in 1.2 for everyone else.

Updated by UGLY58 over 5 years ago

It would be nice in future if you could link this across to the Vector 21 in order to generate target coordinates. So if a player has both he can generate accurate coordinates. As most of the Artillery system mods require grids to be input this would be a nice addition. It would also be a nice complement to the release of the 60mm Mortar.

Updated by S2 over 5 years ago

it already does that ugly

Updated by UGLY58 over 5 years ago

Sweet !!!!!

Updated by Sickboy over 5 years ago

  • % Done changed from 30 to 80

Updated by Sickboy over 5 years ago

  • Status changed from Assigned to In progress
  • Assignee changed from Nou to Xeno

Updated by VKing over 5 years ago

From first test looks very nice!
Vector integration worked fine, and with some effort I managed to get the WP stuff to work as well.

I've got a few comments/suggestions for future improvements:
  • (Option for) 8-digit position readout, for own and lased position.
  • DAGR menu button (shift-home) to toggle the menu dialogue on/off.
  • Is the ACE_DAGR item supposed to give you the vanilla map GPS, even if you don't have a vanilla GPS item?
  • Ability to toggle the DAGR/DAGR menu through the self-interaction menu.
  • A way to enable the WP stuff for the supported islands automatically.

Very good work indeed rosuto!

Updated by rosuto over 5 years ago

-Vector info gives: Target Grid Coordinates, Distance, Elevation, Bearing, and Time. But I could throw something into the nearly empty option menu allowing you to select what info you want. Will look into that. (1.3.0)
-Right now there are two ways to close out of the DAGR menu, the power button and the escape key. The problem is the escape key only closes the dialog but the fsm is still running at whatever position it was left at. This would mean some users would have to hit the DAGR menu key twice to get it to open again (one to close the fsm that was still running, and another to open it again). I felt that this just looked bad and decided to change it to the way it currently is: shift+home only opens menu.
-I don't fully understand what you mean here.
-Only if BIS changes the way player addaction works. Until then, no. Reason why is that I wanted vehicle commanders, crew chiefs, copilots, and squad leaders to be able to program waypoints without having to stop and get out of their vehicles.
-Last but not least, a feature that I really wanted to put into the DAGR, but after 12hrs of script searching, I gave up. But maybe all hope is not lost. More to follow later ;)

Updated by VKing over 5 years ago

rosuto wrote:

-Right now there are two ways to close out of the DAGR menu, the power button and the escape key. The problem is the escape key only closes the dialog but the fsm is still running at whatever position it was left at. This would mean some users would have to hit the DAGR menu key twice to get it to open again (one to close the fsm that was still running, and another to open it again). I felt that this just looked bad and decided to change it to the way it currently is: shift+home only opens menu.

Ok, gotcha.

-I don't fully understand what you mean here.

If you have the DAGR item, but not the GPS item, you still have the old GPS functionality. Is that intended?

-Only if BIS changes the way player addaction works. Until then, no. Reason why is that I wanted vehicle commanders, crew chiefs, copilots, and squad leaders to be able to program waypoints without having to stop and get out of their vehicles.

I don't mean the action menu, but the self-interaction menu (i.e. the same way you open the HUNTIR monitor, f.ex.)

-Last but not least, a feature that I really wanted to put into the DAGR, but after 12hrs of script searching, I gave up. But maybe all hope is not lost. More to follow later ;)

Sounds good :)

Updated by rosuto over 5 years ago

-GPS item issue is fixed
-Self-interaction menu is interesting. I like it because we are running out of keyboard keys and although it might take a little bit of time to use, this better simulates the user actually pulling it out of their pocket. Will look into it some more.
-The DAGR will now try to figure out if a map is fully supported, thus saving me a huge headache trying to explain to people how to properly use the DAGR. Fully supported maps are: chernarus, utes, panthera2, isladuala, and namalsk. Other maps will be supported only if someone asks for them, but they must contain numbered grids.

Updated by Xeno over 5 years ago

  • Status changed from In progress to Closed
  • % Done changed from 80 to 100

The feature is in and available with the next update, so close.

If you find any bugs or want improvements please create a new ticket.

Also available in: Atom PDF