Bug #10117

MLRS's and Grad's missile explodes in air.

Added by conKORD over 5 years ago. Updated over 4 years ago.

Status:Rejected Start date:04/15/2010
Priority:Normal Due date:04/16/2010
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

It is BIS thing.
How to reproduce - just shoot from MLRS to any target at distance more than 500m. Every missile will explode in air.

It caused by insufficient lifetime in ammo config.

weapons.pbo/config.bin

class R_GRAD : RocketBase {
hit = 340;
indirectHit = 45;
indirectHitRange = 30;
model = "\ca\weapons\grad";
initTime = 0.05;
timeToLive = 3;
cost = 400;
maxSpeed = 700;
thrustTime = 1;
thrust = 500;
fuseDistance = 5;
CraterEffects = "ArtyShellCrater";
ExplosionEffects = "ArtyShellExplosion";
effectsMissile = "missile5";
whistleOnFire = 2;
whistleDist = 60;
};
class R_MLRS : RocketBase {
hit = 1000;
indirectHit = 100;
indirectHitRange = 40;
model = "\ca\weapons\grad";
initTime = 0.05;
timeToLive = 3;
cost = 400;
maxSpeed = 700;
thrustTime = 1;
thrust = 500;
fuseDistance = 5;
whistleOnFire = 2;
whistleDist = 80;
CraterEffects = "ArtyShellCrater";
ExplosionEffects = "ArtyShellExplosion";
effectsMissile = "missile5";
};

How to fix it . . . obvious =)
Same thing was be fixed some time ago
http://dev-heaven.net/issues/10010

arty_module_test.Chernarus.rar (851 Bytes) conKORD, 04/16/2010 09:37

History

Updated by KingHomer over 5 years ago

conKORD do you have any link how the direct fire mechanisms of MLRS and GRAD work? Is there some sort of targeting device except the integrated FCS?

Updated by q1184 over 5 years ago

They are supposed to be used with the BIS arty module which spawns ballistic warheads when the rocket engines stop to work. Increasing timetolive might spoil the module (or not, requires testing). Also, firing them without targeting makes little sense anyway :)

Updated by columdrum over 5 years ago

Yeah as q1184 said, they are intended to be used with BIS arty module, its nonsense shot randomly without a targeting system.

Updated by conKORD over 5 years ago

q1184 wrote:

They are supposed to be used with the BIS arty module which spawns ballistic warheads when the rocket engines stop to work. Increasing timetolive might spoil the module (or not, requires testing).

No. When using arty module projectiles disappears immidiatly on cannons and mortars. AFAIK same with MLRS and Grad.

Updated by KingHomer over 5 years ago

  • Due date set to 04/16/2010

I ask again, is there any direct targeting system for the MLRS or BM-21, to be used for a direct LOS attack?

Else you should open a ticket in CIT, so BIS knows there is a problem they should fix.

Updated by conKORD over 5 years ago

KingHomer wrote:

I ask again, is there any direct targeting system for the MLRS or BM-21, to be used for a direct LOS attack?

AFAIK no. Anyway it should be targeting system problem, missiles should not explode in air.

Else you should open a ticket in CIT, so BIS knows there is a problem they should fix.

Useless. http://dev-heaven.net/issues/3724 Pchela's bug known 8 months and we have nothing.
State: Assigned, Affected ArmA II version: 1.04.59026 =)

Updated by KingHomer over 5 years ago

  • Status changed from New to Rejected

conKORD wrote:

KingHomer wrote:

I ask again, is there any direct targeting system for the MLRS or BM-21, to be used for a direct LOS attack?

AFAIK no. Anyway it should be targeting system problem, missiles should not explode in air.

The MLRS / GRAD is not supposed to be manned and used to directly shoot anything. Only in combination with the artillery module or some sort of fire mission script.

Along with that, as q1184 answered: Changing values for the systems might spoil the modules or any scripts based on them.

There's nothing we can and will do here (for now).

Updated by conKORD over 5 years ago

Along with that, as q1184 answered: Changing values for the systems might spoil the modules or any scripts based on them.

It's no matter. Anyway arty module doesn't work correctly with Grad and MLRS. I can call arty interface, but it not shows where projectile will hit ground. Same is without ACE mod.
Below is mission example. With mortar it works normally, but with MLRS, Grad and AGS - fail.

Updated by conKORD over 5 years ago

Increasing lifetime to 12 seconds is no matter for any kind of arty modules. For example with arty module in Benny's Warfare all artillery shoots with elevation ~60 degrees. So missile just will explode highter and will not unmask MLRS's position.
And missiles will be able to fly around 3km, that enough for direct fire (or indirect with arty corrector in TeamSpeak).

PS and again, no answer - I'll create new ticket =)

Updated by conKORD over 5 years ago

KingHomer wrote:

The MLRS / GRAD is not supposed to be manned and used to directly shoot anything.

Another argument.
If currently any kinds of arty don't have tools for indirect fire - just give it to us =)

1)Ballistic table.
2)Sight adjustment.
3)T-E (maybe mils is not enought, need more precision).
4)Map rangefinder.
5)Tool to get height of ground at any point af map.
It should be enough.

Hm . . . it is nice idea. Anyway I'll create new ticket soon. I really like my ideas ;D

Also available in: Atom PDF