Feature #10039

Request for flexible loading of vehicle ammunition (in-game)

Added by Dutch about 5 years ago. Updated almost 4 years ago.

Status:Closed Start date:04/09/2010
Priority:Normal Due date:
Assignee:rocko % Done:

100%

Category:Complex
Target version:1.12
Component: Affected Version:
Close Reason:

Description

Summary:
Current vehicles have by default a predefined ammunition type and ammunition capacity as defined by the relative unit config / parameters.
This obstructs the ability to specify/adjust your vehicle ammo loadouts to your tactical mission / task

Steps to reproduce:
-Enter a armed and fully loaded vehicle
-Discharge all or some of its ammunition
-Move to a ammo truck and rearm

Expected result:
Vehicle crew has the ability to select the ammunition type and quantity they want to load / reload onto the vehicle's weapons.
(within the realistic framework of that vehicle's capacity and type usage in reallife off course)

An example: A person sitting in an M1A1 HC, when near a ammo truck, can select the numbers of APDFST/HEAT-MP-T/M1028 to be (re)loaded.
That person could set it so that the ammo truck (re)loads for example 20x APDSFT, 20x HEAT, 0x M1028. Or for example 10x APDSFT, 20x HEAT, 10x M1028.

Observed result:
Truck rearms each of the vehicle's weapons to the maximum as per the unit parameters, within a certain time.
(with the exeption of fully depleted ammunition, which will in some cases not be reloaded)

Possible fix / workaround:
- Customize the current ammo truck / reload script so that a person inside a vehicle can flexibly select the ammo type and quantity for each of the
vehicle's weapon to be (re)loaded, when near an ammo truck or other distribution point. (within reallife framework of that vehicle's number capacity and ammo type usage)

Associated revisions

Revision f0d316f5
Added by rocko almost 4 years ago

~ADDED: Possibility to dynamically reload vehicles (based on conKords balca_reloader), fixes #10039

History

Updated by Dutch about 5 years ago

Arguments:
In real-life, unit commanders on the higher level (Company, battalion and higher), have the ability to divide and assign resources
(in this case ammunition numbers and types) to those unit's which he thinks need that weapons/ammo in order carry out their task.

An example (I will specify it to armor forces since that is what I know most about):
During the U.S. invasion of Iraq in 2003, the U.S. forces expected to be encountering Iraqi heavy and light armor on their way into the land.
Therefore the U.S. division, brigade and battalion commanders made sure that their own armor forces were equiped to fight against these enemy tanks and IFV's.
Specified, the U.S. Abrams ammo storages were then loaded with a majority of ADPSFT and HEAT rounds, since those are the ones used against tanks and light armor.

Nowadays in Iraq, there is not threat anymore of enemy tanks and IFV's but more insurgent infantry dangers instead.
Therefore, to be effective against those, tanks were re-equiped with different ammunition setups.
In this case they were loaded with a majority of HEAT rounds and M1028 canister rounds, to be deployed against light vehicles, infantry and buildings.
No APDSFT needed here since there is no enemy heavy armor threat anymore.

Conclusion:
Commanders assign/specify their (ammo) resources to the task/mission ahead.

ACE-team, I hope you guys can make this applicable ingame- as per the yellow field above described.
Not sure if it's alot of work. Ill be waiting for responses.

R/,

E. Dutch
CEO
Unit 19

Updated by Dutch about 5 years ago

If the above is too much work, another workaround could be to create a couple of predefined selectable loadout settings for each armed vehicle.

Lets say for example:
- Anti heavy armor orientated loadout (a majority of anti heavy armor ammo)
- Anti light armor/heavy armor orientated loadout (a equal mixture of ammo against both light and heavy armor)
- Anti light armor/heavy armor/buildings orientated loadout (a equal mixture of ammo against light-, heavy armor and buildings)
- Anti personnel/buildings/light armor orientated loadout (a equal mixture of ammo against massed personnel / buildings / light armor)
- Etc
- Etc

Updated by KingHomer about 5 years ago

  • Assignee set to zGuba
  • Target version set to 395

Updated by rocko about 5 years ago

  • Target version changed from 395 to Planned (Needs Contributors)

Updated by rocko over 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from zGuba to Sickboy
  • Target version changed from Planned (Needs Contributors) to 1.7
  • % Done changed from 0 to 100

Updated by rocko over 4 years ago

  • Status changed from Resolved to In progress
  • % Done changed from 100 to 90

Updated by Sickboy over 4 years ago

  • Category set to Complex

Updated by Sickboy over 4 years ago

  • Target version changed from 1.7 to 1.8
  • % Done changed from 90 to 60

Updated by conKORD over 4 years ago

Look into balca reloader that included in release. It could be useful.
http://www.armaholic.com/page.php?id=11265
BalCa reloader.
It is a tool to customize ammo loadouts on vehicles. Generally it was designed to give a second life to commonly unused advanced arty shells, but it can much more :) For example it can load Su-34 with only FAB-250. Or 10 R73. Or 10 Kh29. Or various combination of them.
Usage - get close to warfare ammo truck or warfare supply point and select in action menu "Change loadout".

Updated by rocko over 4 years ago

  • Target version changed from 1.8 to 1.9

Updated by Sickboy over 4 years ago

  • Target version changed from 1.9 to 1.10

Updated by rocko about 4 years ago

  • Target version changed from 1.10 to Planned (Needs Contributors)

Updated by rocko almost 4 years ago

  • Assignee changed from Sickboy to rocko
  • Target version changed from Planned (Needs Contributors) to 395

Updated by rocko almost 4 years ago

  • Target version changed from 395 to 1.12

Updated by rocko almost 4 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 60 to 100

Updated by rocko almost 4 years ago

  • Status changed from Resolved to Closed

Available in ACE for OA 1.12 RC1.

Also available in: Atom PDF