Gameplay feedback

Added by kju almost 6 years ago

Been part of the first test session by RIP team.
Attached a few screenshots.

Overall I like the system. Yet right now it seems way more targeted for league use.
It is a very complicated mission system with not enough systems to guide the players.
Also the size of the mid and large version make it very tough to learn new ppl.

Do you want to target public play or league play or both?

Based on your response more feedback.

The server of RIP grinded to halt while playing with 20-30 ppl.
To me it seemed less related to the missions. They were using VOIP, the amount of
player and not enough server resource might be might bet.

Yet only RIP can provide more info. Maybe also constant error written to RPT.

Anyways good job and looking forward to the updates!
If you haven't done so, play a few rounds of AAS by CoolBox to get some ideas.

0007.png (268.9 kB)

0008.png (320.7 kB)

0009.png (299.7 kB)

0010.png (607.8 kB)


Replies (6)

RE: Gameplay feedback - Added by Alan.rio almost 6 years ago

Sorry I haven't been on in a while. While the server is very high spec, two quad cores, 8 gig of ram, 100Mb/s line, we have been having issues with it. We don't know why really, voip is very patchy and when a player connects it grinds to a halt. Our server configs seem to be ok but we have seen many similar problems with other clans, it may actually be down to the @english mod we run the server with.

RE: Gameplay feedback - Added by Xeno almost 6 years ago

Alan, do you set affinity for the A2 server ?

Currently 2 cores are enough for one A2 server. Be sure, if you have running more than one A2 server on your windows server, that two A2 servers don't use/share the same core. Otherwise you'll get lags or bad performance. Use -cpucount too.

Makes me wonder why you do need the english mod on the server though.

Please post your arma2.cfg.
That's the config file where you can do most to increase server fps.

Concerning VoIP, I've deactivated it as it caused troubles specially for Core i7 users. They allmost allways crashed at mission start as soon as they reached the briefing. No VoIP and it is fine.

Best playernumber I've reached so far was 59 players playing a coop mission (closed server). Though we had bad lags when a player that crashed reconnected (bandwith really really explodes when just one JIP player connects) the server never dropped below 15 FPS/simulation cycles. Don't forget, that was with AI.

RE: Gameplay feedback - Added by Xeno almost 6 years ago

One thing more...

Seems that the english mod indeed causes troubles:
http://cfarma2.com/index.php/2009/07/20/english-mod-creates-crashes/

RE: Gameplay feedback - Added by Alan.rio almost 6 years ago

I'll have to ask bearbison about this, he is the guy taking care of our hardware and configs. He is also the only one that can read/edit the config. i'll direct him to this thread. I've seen the config early on but I think he's been tweaking it a lot since.

RE: Gameplay feedback - Added by BearBison almost 6 years ago

Not had any server crashes since the 13th after a bit of tweaking on the configs, current settings:

MinBandwidth=15000000;
MaxBandwidth=100000000;
MaxMsgSend = 1024;
MaxSizeGuaranteed = 1024;
MaxSizeNonguaranteed = 64;
MinErrorToSend = 0.0025;
MaxCustomFileSize=0;

Our server does not run the @English mod but it does allow it's usage by players as many in our clan have the German version but can't speak/read it :)
No server side mods currently running.
Still see some bad lag if a lot of people connect at the same time and have to download such a big map, but personally think this is more of an issue with the game rather than anything else.

We run two servers on the box with each running on two seperate cores with the -cpucount set.

Also found an issue with Core i7 (since I run one) but was more related to random crashes and fixed it by turning of hyperthreading in my BIOS.

RE: Gameplay feedback - Added by Xeno almost 6 years ago

BearBison wrote:

Not had any server crashes since the 13th after a bit of tweaking on the configs, current settings:

Config looks good for PvP missions.

Still see some bad lag if a lot of people connect at the same time and have to download such a big map, but personally think this is more of an issue with the game rather than anything else.

Indeed. Late A1 servers worked perfectly fine. A2 server needs still a lot of optimizing.

(1-6/6)